Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать программу приведения дробей к наименьшему общему знаменателю. Пользователь вводит две дроби. Программа приводит дроби к наименьшему общему

5-9 класс

знаменателю. СРОЧНО

Nyanya1 04 июня 2014 г., 6:52:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lizatrezina
04 июня 2014 г., 9:15:40 (9 лет назад)

Нахождение НОК двух чисел, оформите под вашу задачу
var
 x, y: integer;
function NOD(x, y: integer): integer;
begin
if x<>0 then NOD:=NOD(y mod x, x)
else NOD:=y;
end;
function NOK(x, y: integer): integer;
begin
NOK:=(x div NOD(x,y))*y;
end;
begin
read(x, y);
write(NOK(x, y));
end.

Ответить

Другие вопросы из категории

Черно-белая фотография разбита на точки, каждая из которых кодируется шестью битами информации. Каков информационный объем фотографий 5х8 см, если один

квадратный сантиметр содержит 1764 точки? Необходимо вычислить информационный объем в Кбайт смешанного документа (с точностью до сотых).

Читайте также

Написать программу для определения максимального числа из данных пяти чисел.

Пользователь вводит пять чисел. Программа выводит ответ: "Максимальное число ... ".
Написать программу в "КуМиРе"



Вы находитесь на странице вопроса "Написать программу приведения дробей к наименьшему общему знаменателю. Пользователь вводит две дроби. Программа приводит дроби к наименьшему общему", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.