Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Найти сумму элементов последовательности с точностью 0,001:

5-9 класс

S=1 + 2/(2*3) - 4/(3*9) + 6/(5*27) - 8/(8*81) + 10/(13*243) - ...

EXIMINDS 19 нояб. 2013 г., 14:55:47 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Remzike
19 нояб. 2013 г., 15:51:56 (10 лет назад)

const
    e = 0.000001;

var
    i, f, f1, thn, t: integer;
    s, s1: real;

begin
    i := 0;
    f1 := 1;
    f := 2;
    thn := -1;
    s := 1;
    s1 := 0;
    repeat
        i := i + 1;
        s1 := s;
        thn := thn * -3;
        s := s + 2 * i / f / thn;
        writeln(2 * i, ' ', f, ' ', thn, ' ', s);
        t := f1;
        f1 := f;
        f := f + t
    until abs(abs(s1) - abs(s)) < e;
    writeln(s);
end.

Ответить

Другие вопросы из категории

Программист Сережа написал программу по проверке сбойных секторов на диске. Тестируя программу, Сережа обнаружил, что проверено 25952 сектора. Ровно

через 2 секунды на счетчике опять появилось число, которое читается одинаково в обоих направлениях и является самым близким к 25952. Сколько секторов проверяется за секунду?

Группа школьников пришла в бассейн, в котором 32 дорожки для плавания. Тренер сообщил, что

группа будет плавать на дорожке номер 5. Сколько информации получили школьники из этого
сообщения

Читайте также

1) Удвоить все элементы массива. 2)Найти сумму элементов двух массивов одинаковой размерности. 4) Найти Минимальные элементы массива и

его индекс.

5) Найти максимальные элементы среди положительных элементов массива 6) Найти максимальные элементы среди отрицательных элементов массива

7) Определить количество максимальных элементов массива

P.S Ребят, все в паскале...заранее спасибо=*

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива.

2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива.
3. Массив из 5 целых чисел вводится с клавиатуры в строку. Найти сумму элементов массива, стоящих на чётных позициях. Вывести исходный массив и полученную сумму.
4. Массив из 40 целых чисел из промежутка [10,90] задается с помощью генератора случайных чисел. Найти сумму элементов массива, кратных n . Вывести исходный массив и полученную сумму.
Помогите кто в чем может.



Вы находитесь на странице вопроса "Найти сумму элементов последовательности с точностью 0,001:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.