Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

цикл с параметром паскаль вывести все трехзначные числа оканчивающиеся на 13;42

5-9 класс

Arina59902133 21 янв. 2014 г., 22:17:53 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
руссич
21 янв. 2014 г., 23:17:48 (10 лет назад)

1)
var i, x: integer;
begin
for i:=1 to 9 do
   begin
   x:=i*100+13;
   write(x: 4)
   end
end.

2)
var i, x: integer;
begin
for i:=1 to 9 do
   begin
   x:=i*100+42;
   write(x: 4)
   end
end.

+ 0 -
Andrei666
22 янв. 2014 г., 1:36:08 (10 лет назад)

Program Thirteen_FortyTwo;
var
  i: integer;
  s: string;
begin
  for i := 100 to 999 do
  begin
    str (i,s);
    if (copy (s, 2, 2) = '13') or (copy (s, 2, 2) = '42') then writeln(s);
  end
end.

Ответить

Другие вопросы из категории

Помогите ,пожалуйста !

Задание 12

У исполнителя Вычислитель две команды, которым присвоены номера:

1. умножь на 2
2. вычти 1
Первая из них увеличивает число на экране в 2 раза, вторая уменьшает его на 1. Составьте алгоритм получения из числа 2 числа 13, содержащий не более 5 команд. В ответе запишите только номера команд.

Предположим,

что на «марсианском» языке выражение «

1)Сколько единиц содержит двоичная запись числа 25?

1.1
2.2
3.3
4.4
2)В системе с некоторым основанием число 17 записывается как 101.Укажите основание.
1.2.
2.3
3.4
4.8
3)В коробке 31 шар.Из них 12 красных и 17 желтых.В какой системе счисления такое возможно?
1 и 2 с решением,если можно.

Читайте также

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3. Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 3. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – максимальное число, оканчивающееся на 3. Пример работы программы: Входные данные Выходные данные 3 23 13 23 3

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 4. Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – минимальное число, оканчивающееся на 4.

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 6. Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 6. Количество чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число минимальное число, оканчивающееся на 6.



Вы находитесь на странице вопроса "цикл с параметром паскаль вывести все трехзначные числа оканчивающиеся на 13;42", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.