Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

В массиве А(20) случайных целых чисел (диапазон чисел [-10..30] ) определить количество нечетных чисел

5-9 класс

DianaLehtera 23 июля 2014 г., 19:15:30 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alenkate
23 июля 2014 г., 21:32:35 (9 лет назад)

var a: array [1..20] of integer; i, s: integer;
begin
     randomize;
     s := 0;
     for i := 1 to 20 do
         a[i] := random(40) - 10;
     for i := 1 to 20 do
     begin
          write(a[i], ' ');
          if (a[i] + 10) mod 2 = 1
          then
              s := s + 1;
     end;
     writeln();
     writeln(s);
end.

Ответить

Другие вопросы из категории

Читайте также

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.
5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.
6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.
б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.
напишите хоть какое нибудь нужно к завтрому срочно

составьте программу которая заполняет массив A состоящая из 20 случайных целых чисел в диапазоне от 1 до 30 и выводит на экран элеме

нты значения которых являются чётными и кратными трём . Пожалуйста помогите решить!!!



Вы находитесь на странице вопроса "В массиве А(20) случайных целых чисел (диапазон чисел [-10..30] ) определить количество нечетных чисел", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.