Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

можете помочь с заданием 5,6,7,8

10-11 класс

Krocus 05 дек. 2016 г., 1:39:30 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kilina00
05 дек. 2016 г., 4:03:44 (7 лет назад)

5) 224(10) -> X(16)
224/16=14, остаток 0
224(10)=E0(16) (выписали частное и остатки в обратном порядке).
Каждую цифру заменяем двоичной тетрадой: 11100000

6) Десятичные числа 1669 и -3210 невозможно представить в виде восьмибитного целого со знаком, потому что в этом представлении число должно быть в пределах -128..127

в)  Представить в нормализованном виде:
58.10=0.581\times 10^2 \\ 600.731=0.600731\times 10^3 \\ 6722.61=0.672261\times 10^4

г) 10010111(2) в дополнительном коде.
Первый разряд единичный, значит это отрицательное число.
Вычтем из него единицу и инвертируем результат.
10010110 -> 01101001 = 64+32+8+1=105(10)
И ставим перед числом знак минус: -105

011001000111 в дополнительном коде. Первый разряд нулевой, значит это положительное число и прямой код совпадает с обратным.
2^{10}+2^9+2^6+2^2+2^1+2^0=1024+512+64+4+2+1=1607_{10}

Ответить

Другие вопросы из категории

Задан ряд последовательных натуральных чисел от n до m (n <m<1000000), из которого удаляют сначала все числа, стоящие на нечетных местах,

затем из оставшегося ряда удаляют все числа стоящие на нечетных местах. Эти действия повторяют до тех пор пока не останется одно число, Определить это число.

Читайте также

Очень вас прошу помочь написать программу.Написать программу-

1)с помощью генератора случайных чисел создать Н числа в диапазоне с [-50;50](длину массива Н надо ввести с клавиатуры)
2)надо вывести сделанный массив на экран
3)нужно вычислить и вывести,какое количество парных чисел
4)и вывести на экран все парные числа.
Очень вас прошу помогите,очень нужно до завтра сделать.Если можете помочь мне,пожалуйста помогите.

Можете помочь? Пожалуйста!

В концептуальную базу ОПП не входит:


1. модульность

2. иерархия

3. абстрагирование

4. инвариантность

5. инкапсуляция

Здравствуйте , задача 6.2 не работает , можете помочь , и желательно с объяснением . =) Я попробовал в Pascal ABC запустить , и она выдаёт пустое

окно .
function len(s: integer): byte;
var i, l: byte;
begin l := s;
while (l > 0) do
begin
l := l div 10;
inc(i);
end;
len := i;
end;
var i: integer;
begin i := 3;
repeat
i := i * 3;
until (len(i) = 6);
writeln(i);
end.

Можете помочь? Пожалуйста!

Под классом понимается:


1. структура, имеющая свойства

2. абстрактный тип данных, включающий набор данных и методов для их преобразования

3. множество объектов, имеющих общую структуру и общее поведение

4. совокупность данных, принадлежащих одному объекту

5. процесс дублирования одинаковых объектов



Вы находитесь на странице вопроса "можете помочь с заданием 5,6,7,8", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.