Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Вводится последовательность целых чисел, по абсолютной величине меньших или равны 100. Найти и вывести на печать количество отрицательных чисел и сумму

10-11 класс

всех чисел, расположенных после первого нулевого элемента.
Написать на Паскале буду очень благодарен!!

БитлЛи 01 нояб. 2014 г., 1:34:26 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dendavydov2001
01 нояб. 2014 г., 2:14:22 (9 лет назад)

program project1;
uses
crt,math;
const n=10;
var 
s:real; 
 i,f,m:byte; 
a:array [1..10] of real;
begin 
m:=0; 
for i:=1 to n do 
 begin 
writeln('vvedite ',i,' cifru');readln(a[i]);
  end;
  for i:=1 to n do 
 begin
  if a[i]<0 then 
 inc(f); 
end; 
for i:=1 to n do 
 begin 
 if a[i]=0 then 
 inc(m); 
 if m<>0 then 
 s:=s+a[i]; 
end;
 writeln('kolichestvo otricatelnih: ',f:2);
 writeln('summa vseh posle 0: ',s:2:2); 
readln;
end.

Ответить

Другие вопросы из категории

Трамвайный билет имеет шестизначный номер(от 100000 до 999999). Выяснить, является ли билет "счастливым". Билет назовем "счастливым", если первая и

последняя цифра билета являются натуральными ( т.е. делятся на 1 и на само себя ).

В процессе преобразования растрового графического файла его объем уменьшился в 2 раза. Сколько цветов было в палитре первоначально, если после

преобразования было получено растровое изображение того же размера в 256-цветовой палитре?

Создать на Паскале форму.

1. Население некоторой страны в 1904 году составляло а человек. По переписи населения, проведенной в прошлом году, зарегистрировано b человек. Составить программу вычисления среднегодового прироста населения за этот период.
2. Составить программу определения, является ли введенный год високосным?
3. Составить программу определения размера денежного вклада через t лет после его внесения, если заданы размер начального взноса n и банковский процент b.
4. Для условий из предыдущей задачи определить, через сколько лет размер вклада превысит вдвое первоначальный взнос.

Читайте также

Вводится последовательность целых чисел, по абсолютной величине меньших или равных 100.Найти и вывести на печать максимальный элемент и число

отрицательных элементов, расположенных после первого нулевого элемента.
Кто может плз очень срочно решить,желательно без массивов,но если не выйдет то через них.На языке Turbo Pascal

Паскаль, 10 класс. Прошу срочно помочь. Заранее спасибо!

Задача №1:
Используя операторы цикла, рассчитать сумму ряда для значений x=0.5; 0.55; 0.6; 0.65; 0.7; 0.75. Включать в сумму члены ряда, большие или равные значению eps=0.00001. Проверить правильность вычислений для контрольной точки x=0.5. Сравнить полученные значения со значениями, рассчитанными по точному аналитическому выражению.
2x3(куб)/3-2x5/15+2x7/35-...+(-1)k+1*2x(2k+1)/4k2-1+..., f(x)=(1+x2)arctgx-x, f(0.5)=0.07955.

Задача №2:
Вводится последовательность целых чисел, по абсолютной величине меньших или равных 100. Найти и вывести на печать количество отрицательных чисел и среднее арифметическое значение всех чисел, расположенных после первого нулевого элемента.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.



Вы находитесь на странице вопроса "Вводится последовательность целых чисел, по абсолютной величине меньших или равны 100. Найти и вывести на печать количество отрицательных чисел и сумму", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.