Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Определить является заданное число трехзначным. Пожалуйста помогите срочно если не сложно то всю программу полностью.

5-9 класс

GOSSIPGIRL55 01 мая 2015 г., 6:56:15 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ирина7352
01 мая 2015 г., 9:18:30 (9 лет назад)

var a : integer;
begin
readln(a);
if (a div 10 >0)and(a div 100>0)and(a div 100<10) then writeln('Число трехзначное')
else writeln('Число не трехзначное');
end.

+ 0 -
Viktoriya123456
01 мая 2015 г., 12:14:10 (9 лет назад)

var n:integer;

Begin

  read(n);

  if (n>99) and (n<1000) then writeln('Yes')

  else writeln('No');

End.

Ответить

Другие вопросы из категории

Запишите команду присваивания, в результате выполнения которой логическая переменная t получает значение TRUE, если выполняется указанное условия, и

значение FALSE в противном случае:
a) x -- положительное число
б) хотя бы одно из чисел x,y,z равно нулю
в) числа x,y,z равны между собой
г) уравнение ax^2+bx+c=0 имеет ровно один корень

Почтовый ящик абонента электронной почты

представляет собой:

СРОООЧНО!!

Какая из указанных ячеек принадлежит диапазону B5:D24? A23

Читайте также

Доброго всем вечера/дня!Пожалуйста,помогите с Информатикой

записать программу в ПАСКАЛЬ(!)
Дано вещественное число — цена 1 кг конфет. Вывести стоимость 1, 2, …, 10 кг конфет.
И если не сложно,то с подробными объяснениями!!!




Всем заранее спасибо!!!)

Пожалуйста, помогите) Очень важно) Решите хотя бы одну задачу... А если не сложно, то лучше 2 :))) 1) Информационная ёмкость

человеческой яйцеклетки приблизительно равна 2 в 33 степени битов. Сколько дискет ёмкостью 1,4 МБайт потребуется для размещения этой информации ?

2) Дискета объёмом 1440 КБайт весит 20 г. Сколько будет весить набор дискет, необходимый для полногокопирования информации с жёсткого диска объёмом 80 ГБайт ?

Заранее огроооомное спасибо :)

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.



Вы находитесь на странице вопроса "Определить является заданное число трехзначным. Пожалуйста помогите срочно если не сложно то всю программу полностью.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.