Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

с клавиатуры вводятся 3 числа x,y,z.Вычислить значения выражений x+y+z и x*y*z и максимальное из них вывести на экран. в паскале

5-9 класс

Sevrukova200086 18 янв. 2014 г., 2:07:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Adel200012345
18 янв. 2014 г., 2:45:34 (10 лет назад)

var x,y,z,a,b: integer;
begin
readln (x);
readln (y);
readln (z);
a:=x+y+z;
b:=x*y*z;
if a>b then writeln (a);
if b>a then writeln (b);
end.

Ответить

Другие вопросы из категории

В вымышленной спортивной игре квиддич соревнуются две команды. Каждый гол, забитый в ворота противника, приносит команде 10 очков. Если же игрок одной из к

оманд поймает специальный мяч снитч, то эта команда получает дополнительные 150 очков, после чего игра заканчивается.
В финале очередного чемпионата Хогвартса по квиддичу встретились команды Когтеврана и Пуффендуя. На протяжении всего матча команды сражались на равных, разница в счете никогда не превышала 10 очков (то есть одного гола), и в конце матча лидировал Когтевран, но благодаря пойманному снитчу победил Пуффендуй. Также после окончания матча журналисты опросили всех игроков, забивших хотя бы один гол.
Алиса сказала, что забила только один гол --- на 27 минуте.
Боб забил один гол на 30 минуте.
Виктория забила два гола --- на 5 и 21 минутах.
Глория забила четыре гола на 10, 12, 34 и 53 минутах.
Дональд забил два гола 14 и 42 минутах.
Эдвард забил три гола на 15, 23 и 56 минутах.
Выполните задания:
1. Укажите, с каким счетом закончилась игра (не забудьте, что снитч приносит 150 очков).
2. Для всех перечисленных игроков укажите, за какую команду они играли.

1.Получено сообщение инормационный объем которого 24576 бит.Чему равен объем в байтах, кб?

2.На каждой странице книги помещается 32 строчки. В каждой строчке 64 СИМВОЛА , книга состоит из 30 страниц. Какой информационный объем в кб содержит эта книга? Сколько таких книг можно разместить на 3-ох тюймовой дискете ( 3 дюйма- 7,44 кб )

Читайте также

1.С клавиатуры вводится действительное число a.Найти его квадратный корень.

2.С клавиатуры вводится действительное число p.Записать отдельно его целую часть C.
Помогите составить программу.

Дан массив из N элементов(12 элементов), заданный случайным образом от -10 до 10. Вывести на экран этот массив. С клавиатуры вводятся два числа меньше N.

Вывести на экран часть массива входящих в диапазон, двух введенных чисел. Эти два числа будут индексами к тем числам, которые надо вывести.

Вводятся 4 числа. Вывести на экран максимальное

Вводятся три числа. Вывести на экран число с минимальной суммой цифр.

Помогите пожалуйста в Паскале

Задание1. Значение переменной Х ввести с клавиатуры. Переменной У присвоить значение 5. Вывести на экран информацию «знач.Х»+5=

«итог. сумма».

Задание 2.

Переменной Х присвоить значение 7. Переменной Р присвоить значение, равное квадрату Х. Вывести значения переменных Х и Р (через запятую). Значение Х увеличить на Х. Переменной Р присвоить значение, равное корню квадратному из Х. Вывести значения переменных Х и Р (через запятую).

DIKTANT 2

Задание 1.

Значение переменной Х присвоить в программе. При неотрицательном значении Х переменной У присвоить значение, равное корню квадратному из Х. В противном случае, переменной У присвоить значение, равное квадрату Х. Вывести на экран значение Х и значение У.

Задание 2.

Двум произвольным переменным присвоить произвольным образом соответственно 2 числа. Двум другим переменным присвоить значения, равные тангенсам двух предыдущих переменных. Вывести на экран значения всех переменных, а так же сумму значений двух последних переменных. помогите сделать пож

2. Определить, делится ли введенное число "а" на 3. Если делится то вывести на экран "Число делится на 3".Тип переменной определить самостоятельно. При

составлении условия учесть, что если число делится на 3, то то остаток от деления на 3 должен быть равен 0.

3. Дана программа на языке Паскаль.
var a,n,s: integer;
begin
s:=0;
n:=0;
repeat;
write('Введите число ');
readln(a);
s:=s+a;
n:=n+1;
until s>100;
writeln('Количество введенных чисел = ' ,n);
end.
Переписать программу используя цикл While.

4. Вывести на экран массив целых чисел, Состоящий из 15 элементов, значение которого из которых сгенерировано случайным образом из диапазона [20,60].



Вы находитесь на странице вопроса "с клавиатуры вводятся 3 числа x,y,z.Вычислить значения выражений x+y+z и x*y*z и максимальное из них вывести на экран. в паскале", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.