Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Какое значение получит переменная Х в результате выполнения оператора присваивания? В:=5; Х:=-3*В; Х:=5-Х

5-9 класс

Ivanushkin7 27 янв. 2015 г., 1:44:28 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
данил753421
27 янв. 2015 г., 3:12:18 (9 лет назад)

X:=20

 

//Решение должно иметь от 20 до 5000 символов

+ 0 -
Mishano
27 янв. 2015 г., 6:06:52 (9 лет назад)

X:=20

 

//Решение должно иметь от 20 до 5000 символов

Ответить

Читайте также

Выберите правильные ответы

1. Закончите предложение: «Алгоритмом называется …»
а) нумерованный список б) маркированный список
в) система команд исполнителя
г) конечная последовательность шагов в решении задачи, приводящая от исходных данных к требуемому результату
2. Что можно считать алгоритмом?
а) правила техники безопасности б) список класса
в) кулинарный рецепт г) перечень обязанностей дежурного по классу
3. Закончите предложение: «Блок-схема – форма записи алгоритмов, при которой для обозначения различных шагов алгоритма используются ….»
а) рисунки б) списки в) геометрические фигуры г) формулы
4. Закончите предложение: «Геометрическая фигура параллелограмм
используется в блок-схемах для обозначения ….
а) начала и конца алгоритма б) ввода или вывода данных
в) принятия решения г) выполнения действия
5. У какого из известных Вам исполнителей следующая СКИ: вверх, вниз, вправо, влево, закрасить?
а) РОБОТ б) Чертежник в) Вычислитель г) ГРИС
6. В следующем списке 12 2,3 0 5 -5 98,0 целых величин:
а) 2 б) 3 в) 4 г) 5
7. Каждая команда алгоритма должна определять однозначное действие исполнителя. Это свойство алгоритма называется…
а ) формальность б) точность в) понятность г) массовость
8. Укажите формальных исполнителей:
а) симфонический оркестр исполняет музыку Ф. Шопена
б) ученик 9 класса решает задачу по алгебре
в) фармацевт готовит лекарство по рецепту
г) автомат на конвейере наполняет бутылки лимонадом
9. Для многократного выполнения одинаковых действий в алгоритме нужно использовать
а) ветвление б) цикл в) линейные команды
10. После выполнения фрагмента алгоритма вида:
S:=0
i:=1
пока i<4
нц
i:=i+1
S:=S+1
кц
значение переменной s равно…. а) 0 б) 3 в) 5 г) 9
11. Переменная х получила значение, равное -6. Какое значение получит переменная у после выполнения ветвления:
если а меньше или равно 3
то у:=а*а
иначе у:= 2а-3
все
а) -6 б) 6 в) 36 г) -15

1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a := 3 + 8*4; b :=

(a div 10) + 14;

a := (b mod 10) + 2;

2) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 1819;

b := (a div 100)*10+9;

a := (10*b–a) mod 100;

3) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 42;

b := 14;

a := a div b;

b := a*b;

a := b div a;

4) Определите значение целочисленных переменных x, y и t после выполнения фрагмента программы:

x := 5;

y := 7;

t := x;

x := y mod x;

y := t;

5) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

а :=6*12 + 3;

b :=(a div 10)+ 5;

a :=(b mod 10)+ 1;

Дан условный оператор:

if a<5 then c:=1

else if a>5 then c:=2
else c:=3

какое значение имеет переменная a, если в результате выполнения условного оператора переменной c присваиваетсязначение 3?

вариант 1

1.По какой команде будет выведено значение величины Х?
1)readln(x);
2)read (x);
3)write( 'x' );
4)write(x).
2.Найдите синтаксические ошибки в программе:
Program Pr;
Var a,b.c: real;
Begin
write 'введите два числа ;
read a,b;
c=a/b*0,01
wrire ('c=,c');
End.
3.Какое значение пример переменная z после выполнения команд:
z:=0; x:=-1; y:=-1;
if x>0 then z:=1
else z:=2;
1)2; 2)-1; 3)1; 4)0; 5) ни один из ответов 1-4 не верен.
4.Какое логическое выражение нужно вписать во фрагмент программы,определяющий минимальный элемент массива F[1..N]?
x:=F[1];
For k:=1 to N do
If_________then x:=F[k];
1)F[k]<x; 2)F[k]>=F[k-1]; 3)F[k]<0; 4)k<=N;
2)ни один из ответов 1-4 не верен
5.Чему было равно значение переменной у,если после выполнения операций
i:=10;
while i <>1 do
begin
y:=y*y;
i:=int ( i / 2 );
end;
оно стало равным 256?
1) 2; 2) -2; 3) 0; 4) 2 или -2; 5) ни один из ответов 1-4 не верен.
6.Что будет выведено на печать в результате выполнения следующих операторов :
а:='5'; b:=-5;
write (pred (a), succ (a), 'b=', 10+b);
1)'4' '6' b=5; 2) 64b = 10+b; 3)46b=5; 4)64b=5; 5) ни один из ответов 1-4 не верен.
7.Что будет выведено на печать в результате выполнения следующих операторов:
а:=1;
repeat
a:=а+1;
write ('a=',a);
until a=4;
1)a=2a=3a=4a=5a ; 2) a=2a=3a=4 ; 3)а=4 ; 4) а=3 ; 5) ни один из ответов 1-4 не верен.



Вы находитесь на странице вопроса "Какое значение получит переменная Х в результате выполнения оператора присваивания? В:=5; Х:=-3*В; Х:=5-Х", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.