Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

даны строки S , S1, S2. Заменить в строке S все вхождения строки S1 на строку S2 .

10-11 класс

19850723 22 нояб. 2014 г., 22:14:43 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
WildWolf1
23 нояб. 2014 г., 0:33:21 (9 лет назад)

var
s1,s2,s3:string;
i,j:longint;
begin
readln(s1,s2,s3);
for i:=1 to length(s1);
begin
k:=pos(s2,s1);
if k>0 then begin
delete(s1,k,length(s2));
insert(s2,s1,k); {Не помню точно, в каком порядке первые 2 переменные}
writeln(s1); end else exit; end;
end.

Ответить

Другие вопросы из категории

Нужен список всех операторов Pascal

В виде

Оператор

помогите пожалуйста!

нужно привести примеры перехода от порядка к хаосу в окружающем мире.

Помогите решить задание 5.

Читайте также

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Помогите пожалуйста решить))) или хотя бы натолкнуть на мысль )) 1) Записать элементы массива Х, удовлетворяющие условию 1≤Xi≤2, подряд в массив

Y. Поменять местами максимальный и минимальный элементы в массиве Y.

2) Заменить строку матрицы Р(n,m) с минимальной суммой элементов на строк, где находится максимальный элементы матрицы.

3) Определить, пересекаются ли параболы у=ах2+bc+c и y=dx2+mx+n. Если пересекаются, то найти точку пересечения.

Дана исходная строка: “12”. Ее обработали по следующему алгоритму: в конец строки дописали ее зеркальную копию, а затем к цифрам стоящим на четных

позициях считая слева направо, прибавили по 1. Получилась строка: “1322”. Указанный алгоритм обработки применили к этой получившейся строке, затем к строке, которая получилась в результате новой обработки и т.д. Например, после трех применений алгоритма обработки получились следующие строки:

12

1322

14232332

1524243324333342

Посчитай количество нечетных цифр в строке, получившейся после шестого применения алгоритма обработки. В ответе укажите целое число.

Паскаль:

1) дана строка символов, в которой есть хотя бы вхождение 'abc'. Все вхождения 'abc' заменить на 'def'

2) в заданном тексте все встретившееся буквы 'a' удалить, а буквы 'd' удвоить



Вы находитесь на странице вопроса "даны строки S , S1, S2. Заменить в строке S все вхождения строки S1 на строку S2 .", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.