Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найти номера и количество элементов кратных 5

5-9 класс

оля7ля 30 мая 2014 г., 8:06:09 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Liza2709
30 мая 2014 г., 11:04:45 (9 лет назад)

program z1;
var a:array[1..1000] of integer;
        i,n:integer;
        s:int64;
begin
        assign(input,'in.txt');
        reset(input);
        assign(output,'out.txt');
        rewrite(output);
        s:=0;
        readln(n);
        for i:=1 to n do begin
                read(a[i]);
                if (a[i] mod 5)=0 then begin
                        write(i,' ');
                        s:=s+1
                end
        end;
        close(input);
        writeln('');
        writeln('количество=',s);
        close(output)
end.

+ 0 -
Qq22qq1911qwe
30 мая 2014 г., 12:39:12 (9 лет назад)

Комментарий удален

+ 0 -
Bochka00
30 мая 2014 г., 14:44:59 (9 лет назад)

Элементов массива

Ответить

Читайте также

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

составьте программу которая запрашивает значения элементов одномерного числового массива а, стоящего из 10 элементов,формирует и выводит на экран в

строку данный массив. Найти сумму неположительных элементов массива,количество элементов кратных 3, произведение элементов,стоящих на четных местах

Напишите программу, которая в последовательности целых чисел находит сумму и количество чисел, кратных 17, или сообщает, что таких чисел нет. На вход

программы подаются целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (0 - признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введенные числа по модулю не превышают 300. Программа должна вывести сумму и количество чисел, кратных 17, или вывести NO, если таких числе в последовательности нет

Напишите программу, которая в последовательности целых чисел определяет количество чисел, кратных 4 и оканчивающихся на 0. Программа получает на вход целые

числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не является членом последовательности). Количество чисел не превышает 1000. Введеные числа по модулю не превышают 30000. Программа должна вывести число: количество чисел, кратных 4 и оканчивающихся на 0.



Вы находитесь на странице вопроса "Найти номера и количество элементов кратных 5", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.