Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Пожалуйста помогите написать программу в паскале!!!!!!! Даны радиус круга и сторона квадрата. Проверьте, пройдет ли круг в квадрат?

10-11 класс

Iuragerasimov 27 июня 2014 г., 13:35:43 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
987654321milena
27 июня 2014 г., 14:38:39 (9 лет назад)

var r,a:real;

begin

readln(r,a);

if 2*r<a then writeln('proidet') else writeln('ne proidet');

end.

Ответить

Другие вопросы из категории

Читайте также

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Одномерный массив из 6 элементов заполнить случайным образом числами от 5 до 17. Поменять местами 5-ый и 7-ой элементы массива, а 4-ый элемент

увеличить в 3 раза. Вывести на экран монитора первоначальный и преобразованный массивы в строчку.

Пожалуйста, помогите написать программу в Паскале.

алгоритм Мишень цел n, k, i вещ массив P[1000] вещ r1, r2 начало ввести

n, массив P и радиусы r1, r2 /* Исходные данные */

вывести заголовок задачи и значения n, P, r1, r2 k ¬0 для i от 1 до n шаг 1 выполнять/*

Подсчитать число точек */ если r1 < ri и ri < r2 то k ¬k +1

конец-если

конец-цикл

вывести заголовки выходных данных и значений k конец

Теперь спланируем тестирование.

Проверку программы выполним при следующих исходных данных.

Зададим число точек на плоскости: n = 10. Подберем расстояния и радиусы: 0.03 21.0 12.89 7.41 99.99

P = 12.34 56.78 90.98 7.6 0.54

r1 = 12.35 r2 = 56.90.

Выходные данные в этой задаче будут иметь вид: Мишень Исходные данные:

n= 10 Массив P[n]: 0.03 21.0 12.89 7.41 99.99 12.34 56.78 90.98 7.6 0.54 r1 = 12.35 r2 = 56.90

Ответ: внутри 3 точки (три точки находятся внутри кольца).помогите написать программа в паскале и алгоритм блок-схему.пожалуйста срочно!



Вы находитесь на странице вопроса "Пожалуйста помогите написать программу в паскале!!!!!!! Даны радиус круга и сторона квадрата. Проверьте, пройдет ли круг в квадрат?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.