Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Получить новую матрицу путём сложения всех элементов данной матрицы с её наименьшим по модулю элементом.

10-11 класс

Katyshka196546 25 мая 2014 г., 9:57:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Настёныш15
25 мая 2014 г., 11:46:41 (9 лет назад)

var a:array[1..100,1..100] of integer;

i,j,n,min:integer;

Begin

  read(n);

  min:=MaxInt;

  for i:= 1 to n do

    for j:= 1 to n do begin

      read(a[i,j]);

      if abs(a[i,j])<abs(min) then min=a[i,j];        

    end;

  for i:= 1 to n do begin

    for j:= 1 to n do begin

      a[i,j]:=a[i,j] + min

      write(a[i,j]);     

    end;

    writeln;

  end; 

end.

Ответить

Другие вопросы из категории

где можно быстро создать сайт?

Читайте также

В одномерном массиве, состоящем из n целых элементов, вычислить:


1) Сумму модулей элементов массива, больших числа X

2)Сумму модулей элементов массива, меньших числа X

1)Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного.

2)дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов. Использовать три процедуры (заполнение, смена, вывод).

Дана матрица размерностью nxn найти

Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы. Найти квадрат разности среди арифметических значений элементов матрицы ,находящихся ниже и выше главной диагонали

Помогите пожалуйста)) очень-очень срочно(( С# Получить элементы массива А по формуле .... Вычисленый массив вывести на печать.

Найти максимальный по модулю элемент массива А.

Массив я вычислил, а остальное не получается(

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

namespace ConsoleApplication27

{

class Program

{

static void Main(string[] args)

{

int n = 30;

double[] a = new double[30];

for (int i = 0; i <= 20; i++)

{

a[i] = Math.Sqrt(i ^ 2 + 1) - Math.Sin(i / n);

Console.WriteLine("a(" + i + ")=" + a[i]);

}Console.ReadKey();

}

}

}


Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию



Вы находитесь на странице вопроса "Получить новую матрицу путём сложения всех элементов данной матрицы с её наименьшим по модулю элементом.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.