Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста)) очень-очень срочно(( С# Получить элементы массива А по формуле .... Вычисленый массив вывести на печать.

10-11 класс

Найти максимальный по модулю элемент массива А.

Массив я вычислил, а остальное не получается(

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

namespace ConsoleApplication27

{

class Program

{

static void Main(string[] args)

{

int n = 30;

double[] a = new double[30];

for (int i = 0; i <= 20; i++)

{

a[i] = Math.Sqrt(i ^ 2 + 1) - Math.Sin(i / n);

Console.WriteLine("a(" + i + ")=" + a[i]);

}Console.ReadKey();

}

}

}


Svetlanaboloto 20 сент. 2014 г., 5:02:35 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Servisgs
20 сент. 2014 г., 7:28:26 (9 лет назад)

          напишу только основное тело программы:

            int n = 30;
            double[] a = new double[30];
            double maxabs;
            for (int i = 0; i <= 20; i++)
            {
                a[i] = Math.Sqrt(i ^ 2 + 1) - Math.Sin(i / n);
                Console.WriteLine("a(" + i + ")=" + a[i]);
            }
            maxabs = a[1];
            for (int i = 0; i <= 20; i++)
                if (Math.Abs(a[i]) > Math.Abs(a[i+1]))
                    maxabs = a[i];
            Console.WriteLine("Maximum abs = "+maxabs);
            Console.ReadKey();

Ответить

Другие вопросы из категории

На световой панели в ряд расположены 7 лампочек. Каждая из первых двух лампочек может гореть красным, жёлтым или зелёным цветом. Каждая из остальных

пяти лампочек может гореть одним из двух цветов – красным или белым. Сколько различных сигналов можно передать с помощью панели (все лампочки должны гореть, порядок цветов имеет значение)?

--- Задача 7 ---

Просмотрщик
текстовых файлов. Написать программу, которая позволяет просматривать текстовые
файлы (выводит на экран содержимое файла). Имя просматриваемого файла должно
вводиться с клавиатуры. Вывод содержимого файла произвести постранично.

Примечание:
Результат работы с данными вывести на экран и в новый файл. Файл с входными
данными имеет название INPUT.TXT для текстовых файлов.


на PascakABC оч нужно..плизз

Дан

массив из N вещественных чисел. Выделить другим цветом все его
элементы, принадлежащие интервалу [a,b]

Читайте также

Вычислите среднее арифметическое число положительных элементов массива A(N1), B(N2), C(N3)

Помогите пожалуйста очень срочно надо))), заранее спасибо)))

Помогите пожалуйста, очень срочно!

Дан массив А , содержащий N элементов .Найти произведение отрицательных элементов массива и их количество. Нарисовать блок-схему. Просчитать значения: N=10 , массив А={-2;0;10;-1;7;3;0}

Вводится последовательность целых чисел, по абсолютной величине меньших или равных 100.Найти и вывести на печать максимальный элемент и число

отрицательных элементов, расположенных после первого нулевого элемента.
Кто может плз очень срочно решить,желательно без массивов,но если не выйдет то через них.На языке Turbo Pascal

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .



Вы находитесь на странице вопроса "Помогите пожалуйста)) очень-очень срочно(( С# Получить элементы массива А по формуле .... Вычисленый массив вывести на печать.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.