Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Решить задачу в паскаль

10-11 класс

Hgftr 09 янв. 2015 г., 7:00:10 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Glebon1986
09 янв. 2015 г., 8:03:06 (9 лет назад)

procedure GetWord(var pStr: string; var pCur: integer; var pRes: string);
var
  i, l: integer;
begin
  l := length(pstr);
  if pCur >= l then begin
    pCur := 0;
    pRes := ''
  end
  else begin
    i := PosEx(' ', pStr, pCur);
    if i > 0 then begin
      pRes := Copy(pStr, pCur, i - pCur);
      pCur := i + 1
    end
    else begin
      pRes := Copy(pStr, pCur, l - pCur + 1);
      pCur := l;
    end
  end
end;

procedure DeleteCaps(var s: string);
var
  i: integer;
  ps: string;
begin
  ps := '';
  for i := 1 to length(s) do
    if (s[i] < 'A') or (s[i] > 'Z') then
      ps := ps + s[i];
  s := ps
end;

var
  w, s, sMax: string;
  i, l, lMax: integer;

begin
  writeln('Введите строку');
  readln(s);
  i := 1;
  sMax := '';
  lMax := 0;
  repeat
    GetWord(s, i, w);
    if i > 0 then begin
      l := length(w);
      if l > lMax then begin
        lMax := l;
        sMax := w
      end
    end
  until i = 0;
  DeleteCaps(sMax);
  writeln('Все, что осталось от самого длинного слова: ', sMax);
end.

Результат теста:

Введите строку
THe QiuCk BroWN Fox jUMpS oVER the LazY dOg
Все, что осталось от самого длинного слова: iuk



Ответить

Другие вопросы из категории

Вопрос жизни и смерти:

4 ЗАДАНИЕ!

1) Чему равно 3 в шестой степени?

2) Найти с помощью программы чему равно выражение (15*2+8)-1, если есть всего 3 переменные x, y, z

Всё это посчитать в ПАСКАЛЕ!ПОМОГИТЕ,ПОЖАЛУЙСТА!

Читайте также

Решить задачу в Паскале:

Задать случайным образом 8
элементов числового массива – числа от 100 до 200. Вставить в него:

а) число «-20» перед 5-ым
элементом.

б) число «0» перед максимальным элементом. В одной задаче должно быть и а и б (но можно и по отдельности, главное, чтобы было верно)))

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.

Нужно решить задачу в Паскале, условие таково:

"Найти наименьшее кратное двух чисел a и b"

Насколько я помню в этой задаче можно использовать команду Break.


Помогите решить задачу на Паскале.

Дана строка.Перенести последнюю букву слова в начало слова

Помогите, пожалуйста, решить задачи в паскале :

1.Определите сколько нечетных чисел среди четырех заданных чисел
2.Вычислите, является ли четырехзначное число счастливым



Вы находитесь на странице вопроса "Решить задачу в паскаль", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.