Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста. (нужно решить в паскале) Дано масив А[1..n, 1..m]. Скласти програму пошуку всіх елементів масиву А, що менші ніж усі сусідні.

10-11 класс

Angelina7799 05 сент. 2013 г., 23:57:41 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Svetlanamur
06 сент. 2013 г., 0:56:49 (10 лет назад)

Program Julia9696;
uses crt;
const
n=10;
m=8;
var
A:array[1..n,1..m] of integer;
cur,up,right,down,left,qw,i,j:integer;
begin;
randomize;
writeln('******* Alphaeus *******');writeln;
writeln ('Програма пошуку всіх елементів масиву А[1..n, 1..m], що менші, ніж усі сусідні');
for i:=1 to n do
begin
for j:=1 to m do
begin
A[i,j]:=random(101)-50;
write(A[i,j]:3, ' ');
end;
writeln;
end;
writeln;
qw:=0;
for i:=1 to n do
for j:=1 to m do
begin
cur:= A[i,j];
up:=0; right:=0;down:=0;left:=0;
if i>1 then
begin
if cur<A[i-1,j] then up:=1;
end
else up:=1;
if i<n then
begin
if cur<A[i+1,j] then down:=1;
end
else down:=1;
if j>1 then
begin
if cur<A[i,j-1] then left:=1;
end
else left:=1;
if j<m then
begin
if cur<A[i,j+1] then right:=1;
end
else right:=1;
if up+right+down+left=4 then
begin
qw:=qw+1;
writeln('Елемент масиву À[',i,',',j,'], що рівний ',A[i,j]:3,', є меншим за своїх сусідів');
end;
end;
writeln('Всього таких елементів: ',qw);
end.

Ответить

Другие вопросы из категории

сделайте пожалуйста))))

В приведенной таблице ниже указаны возраст и фамилии сотрудников одного офиса. Расположите фамилии в соответствии с возрастными категориями, указанными в таблице. Запишите необходимые формулы в ячейки: C2, D2, E2.

Для музыкальной композиции производится одноканальная (моно) звукозапись с частотой дискретизации 128 Гц. При записи использовались 16 уровней

дискретизации. Графический файл содержал 16384 пикселей, кодированных с использованием палитры из 256 цветов. И в файле с музыкальной композиции и графическом файле не использовалось сжатия данных. Кроме упомянутых скачиваемых файлов другой нагрузки на канал доступа в интернет не было. Сколько секунд длиться музыкальная композиция которую скачал Иван? В ответе укажите целое число секунд. Единицы измерения в ответе не указывать.

Читайте также

Помогите пожалуйста. Нужно решить в паскале.

Дано масив А[1..n]. Скласти програму підрахунку суми всіх елементів, що знаходяться між елементами А[1] і А[n].

Помогите пожалуйста, нужно сделать в паскале, в экселе, и блок-схему!

(задание номер 5 на фото)

Дан одномерный массив А размерностью 16. Определить максимальное значение среди нечетных элементов массива, и минимальное среди четных элементов массива. Получить сумму максимального и минимального значений элементов массива и преобразовать данный массив по принципу из значений нечетных элементов вычесть сумму, а к четным элементам прибавить сумму. Все первоначальные элементы массива вводятся с клавиатуры.



Вы находитесь на странице вопроса "Помогите пожалуйста. (нужно решить в паскале) Дано масив А[1..n, 1..m]. Скласти програму пошуку всіх елементів масиву А, що менші ніж усі сусідні.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.