Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

нужны примеры по алгоритмическим структурам - линейный алгоритм, цикл с предусловием и цикл с постусловием.

10-11 класс

Аринаghf 03 авг. 2013 г., 8:28:12 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Art9055
03 авг. 2013 г., 9:10:41 (10 лет назад)

Программа имеет линейную структуру, если все операторы (команды) выполняются последовательно друг за другом.

                                         




Командой повторения, или 

+ 0 -
Ksyushatimofee
03 авг. 2013 г., 10:45:54 (10 лет назад)

в маили есть ответ!!!!!!!!!!

Ответить

Другие вопросы из категории

Для музыкальной композиции производится одноканальная (моно) звукозапись с частотой дискретизации 128 Гц. При записи использовались 16 уровней

дискретизации. Графический файл содержал 16384 пикселей, кодированных с использованием палитры из 256 цветов. И в файле с музыкальной композиции и графическом файле не использовалось сжатия данных. Кроме упомянутых скачиваемых файлов другой нагрузки на канал доступа в интернет не было. Сколько секунд длиться музыкальная композиция которую скачал Иван? В ответе укажите целое число секунд. Единицы измерения в ответе не указывать.

Var a:array [1..100,1..100] of real;

b:array [1..100,1..100] of real;
i,m,n,c:integer;
begin
readln(n);
readln(c);
for i:=1 to n do
for m:=1 to c do readln(a[i,m]);
for i:=1 to n do
for m:=1 to c do
b[i,m]:=a[i,m]/8;
for i:=1 to n do
for m:=1 to c do writeln(b[i,m]);
end.
можете написать обозначение каждого символа

1.

Читайте также

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

1)Найдите сумму натуральных нечетных чисел не превышающих n!!!!Это нужно сделать циклом for. 2) Составьте программу,которая производит

суммирование произвольного количества целых чисел вводимых с клавиатуры.Концом последовательности служит ввод отрицательного числа.Программу составьте двумя способами: использую цикл с предусловием и цикл с постусловием



Вы находитесь на странице вопроса "нужны примеры по алгоритмическим структурам - линейный алгоритм, цикл с предусловием и цикл с постусловием.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.