Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Известна диагональ прямоугольника и угол между диагональю и большей стороной. Вычислить площадь прямоугольника .

10-11 класс

Нужно написать линейный алгоритм.

Adelinochka84 03 июня 2013 г., 20:04:48 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lenusha27
03 июня 2013 г., 22:46:15 (10 лет назад)

var
  a, b, d, s, alpha: real;

begin
  Write('Введите длину диагонали прямоугольника: ');
  Readln(d);
  Write('Введите величину угла между большей стороной и диагональю :');
  Readln(alpha);
  alpha := Pi * alpha / 180;
  a := d * cos(alpha);
  b := d * sin(alpha);
  s := a * b;
  Writeln('Площадь прямоугольника равна ', s:0:3)
end.

Тестовое решение:

Введите длину диагонали прямоугольника: 35
Введите величину угла между большей стороной и диагональю :29
Площадь прямоугольника равна 519.429



Ответить

Другие вопросы из категории

1) Составить фразу "волчий аппетит" из слов "аптека", "ствол", "чайник".

2) Вывести на экран первую букву третьего слова данного текста. Если нет третьего слова, то вывести сообщение "ошибка".

помогите пожалуйста решить задачи и закодировать их в программе visual foxpro 9.0!!!!!

1) определить время через которое встретятся два тела равноускоренно движущиеся навстречу друг другу,если известны их начальные скорости ускорения и начальное расстояние между ними.
2)даны целые числа m,n (0<m<или равно12,0<или равно n<60),указывающий момент времени:" m часов, n минут" .Определить наименьшеевремя(число полных минут),которое должно пройти до того момента когда часовая и минутная стрелки на циферблате совпадут.

ну оооочень нужно!!!!!!

Составьте программу, которая:

в) заменяет в формуле, заданной с клавиатуры, круглые скобки на квадратные.

ПРОШУ ПОМОГИТЕ РЕШИТЬ! 10 КЛАСС

ЗАДАНИЕ 1
Перевести целые числа из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную системы:
а) 856; б) 664; в) 5012; г) 6435; д) 78.

Читайте также

Однажды, посетив магазин канцелярских товаров, Вася купил X карандашей, Y ручек и Z фломастеров. Известно, что цена ручки на 2 рубля больше цены

карандаша и на 7 рублей меньше цены фломастера. Также известно, что стоимость карандаша составляет 3 рубля. Требуется определить общую стоимость покупки.

Входные данные

В единственной строке входного файла INPUT.TXT записаны три натуральных числа X, Y и Z через пробел, каждое из которых не превышает 109.

Выходные данные

В выходной файл OUTPUT.TXT выведите одно целое число – стоимость покупки в рублях.

Описать

процедуру RectDiag(a, b, d), вычисляющую диагональ
прямоугольника со сторонами a, b (a, b — входные, d
— выходной параметр вещественного типа).

1)Стороны прямоугольника параллельны осям координат.Одна из вершин имеет координаты (0,0),координаты противоположной вершины задаются с

клавиатуры.Вычислите площадь прямоугольника. 2)С клавиатуры вводится натуральное число.Если оно кратно двум,напишите "четное число",иначе напишите "нечетное число".

ПОМОГИТЕ СРОЧНО!!

На схеме указаны дороги между четырьмя населёнными пунктами и отмечены длины этих дорог.Длина одной дороги неизвестна. Зато известно,что самый короткий путь между двумя наиболее удалёнными друг от друга населёнными пунктами составляет 70 км.Найдите длину неизвестной дороги,ответ запишите целым числом



Вы находитесь на странице вопроса "Известна диагональ прямоугольника и угол между диагональю и большей стороной. Вычислить площадь прямоугольника .", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.