Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите с информатикой пожалуйста (Написать короткую програмку в FreePascal)

5-9 класс

Ввести 2 числа, если сумма четная делить на 2, если нет оставить без изменений. Заранее спасибо)

GulyaAlina 28 янв. 2017 г., 14:52:21 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Glabalnaya
28 янв. 2017 г., 15:32:41 (7 лет назад)

var
  x,y:integer;
begin
  writeln('Введите 1-ое число');
  readln(x);
  writeln('Введите 2-ое число');
  readln(y);
  if ((x+y)mod 2)=0 then writeln('Ответ: ',(x+y)/2)
  else writeln('Ответ: ',x+y) 
end.

Ответить

Другие вопросы из категории

1. К какому типу относится переменная А:=0.25?а) char; б) integer; в) boolean; г) real.2. Определите, является ли число М нечетным. Какое условие можно

использовать в этой задаче?а) M mod 2<>0; б) M/2<>0; в) M div 2<>0; г) M='нечетное'.3. Входит ли число А в диапазон значений [4;10)? Какое составное условие нужно поставить в этой задаче?а) (A>=4) and (A<10); б) (A<=4) and (A>10); в) (A>=4) or (A<=10); г) not (A>=4) and not (A<10).4. Какое условие следует использовать для вычисления Y по формулам: Y=(X+1)2, при X≥1; Y=cosX, при X<1?а) if x>=1 then y:=cos(x) else y:=sqr(x+1); б) if x<1then y:=cos(x) else y:=sqr(x+1); в) if x>=1 then y:=sqr(x+1) else y:=cos(x); г) if x>1 then y:=cos(x) else y:=sqr(x+1);5. Что будет выведено на экран после выполнения фрагмента программы?begina:=1; b:=1;if (a>=1) and (b>=2) then n:=a+b else n:=a-b;writeln(n);end.а) 3; б) -1; в) 1; г) 0.6. Есть ли в следующих текстах пустые операторы? (В ответе перечислите буквы через запятую)а) begin a:=true; b:=b end б) if a div b=0 then else b:=0 в) begin x:=-2; y:=-5; end г) begin if x=0 then x:=2; y:=xд) if x>0 then x:=3 else; y:=x-27. Найдите ошибки в следующих операторах и запишите исправленные операторы.а) begin if y2>1 then y:=cosy; y:=; end;б) if -2<y<5 then if y>=1 then y=y3 else y:=y2else y:=sqr(y)8. Напишите программу, которая по номеру дня недели показывает название этого дня недели.

Помогите решить задачу в Excel:Билет на пригородном поезде стоит 5 монет,если расстояние до станции не больше 20 км;13 монет,если расстояние больше 20

км,но меньше 75 км;20 монет,если расстояние >= 75 км.Составить таблицу,по которой можно определить цену билета до 10 станций.Построить диаграмму,показывающую соотношение цен всех билетов.

Читайте также

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.

Помогите с информатикой,пожалуйста.

Между девятью планетами Солнечной системы
введено космическое сообщение. Ракеты летают по следующим маршрутам:
Земля—Меркурий, Плутон—Венера, Земля—Плутон, Плутон—Меркурий, Меркурий—Венера,
Уран—Нептун, Нептун—Сатурн, Сатурн—Юпитер, Юпитер—Марс и Марс—Уран. Можно ли
добраться с Земли до Урана?

Отдам 30 БАЛЛОВ!

Помогите с информатикой пожалуйста!
8 и 9 номер



Вы находитесь на странице вопроса "Помогите с информатикой пожалуйста (Написать короткую програмку в FreePascal)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.