Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составить программу, формирующую массив b[2],каждый элемент которого является максимальным из соответствующих элементов массивов а[4] и с[4]

10-11 класс

Butrinov2003 14 окт. 2013 г., 15:23:14 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Wwwyuliswatro
14 окт. 2013 г., 18:05:55 (10 лет назад)

var
   i:integer;
   a,c:array[1..4]of integer;
   b:array[1..2]of integer;
begin
write('Массив а: ');
for i:=1 to 4 do
  begin
  a[i]:=random(10);
  if a[i]>b[1] then b[1]:=a[i];
  c[i]:=random(10);
  if c[i]>b[2] then b[2]:=c[i];
  write(a[i],' ');
  end;
writeln;
write('Массив c: ');
for i:=1 to 4 do  write(c[i],' ');
writeln;
write('Массив b: ');
for i:=1 to 2 do  write(b[i],' '); 
end.

Ответить

Другие вопросы из категории

D:\ДОКУМЕНТЫ\ФОТО\2011\ВЕСНА

Сначала он поднялся на три уровня вверх, потом спустился в каталог ЭКЗАМЕН и после этого спустился в каталог ИНФОРМАТИКА. Укажите полный путь для того каталога, в котором оказался пользователь (запишите номер правельного ответа):
1) D:\ДОКУМЕНТЫ\ФОТО\ИНФОРМАТИКА
2) D:\ДОКУМЕНТЫ\ФОТО\ИНФОРМАТИКА\ЭКЗАМЕН
3) D:\ДОКУМЕНТЫ\ЭКЗАМЕН\ИНФОРМАТИКА
4) D:\ДОКУМЕНТЫ\ФОТО\2011\ВЕСНА\ЭКЗАМЕН\ИНФОРМАТИКА

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям:автор, название, год издания. Провести сортировку и

вывести список книг, изданных после 2003 года.



2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.

введите с клавиатуры одномерный массив D(N), элементами которого являются положительные и отрицательный целые числа. Сформируйте новый массив B(V) из

положительных элементов и С(М) из отрицательных элементов. В массиве D(V) определите максимум, а в массиве С(М)-минимум.

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.

вот задание: дано: массивы А(10),В(10),С(10). Сформировать массив D(10), каждый элемент которого есть максимальное значение соответствующих

элементов А,В,С, т.е. Di=MAX{Ai,Bi,Ci}. Нахождение максимального значения оформить в виде подпрограммы.а вот подпрограмма:

Procedure FindMax(A,B,C:real; Var D:real);
Begin
if (A>B)and(A>C) then D:=A;
if (A<B)and(B>C) then D:=B;
if (C>B)and(A<C) then D:=C;
End;
Var
A,B,C,D:array[1..10] of real;
i:integer;
Begin
Write('A: ');
For i:=1 to 10 do
Begin
A[i]:=random(100)-25;
Write(A[i],' ');
End;
WriteLn;
Write('B: ');



Вы находитесь на странице вопроса "Составить программу, формирующую массив b[2],каждый элемент которого является максимальным из соответствующих элементов массивов а[4] и с[4]", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.