Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Выполните в двоичной системе счисления следующие арифметические операции: а)21+13 б)21-13 в)9*3 г)40/4

5-9 класс

LevanovaM 11 авг. 2014 г., 0:07:59 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mk050881pkm
11 авг. 2014 г., 3:03:15 (9 лет назад)

Чтобы выполнять действия в двоичной системе необходимо числа в эту самую двоичную систему перевести:

 

21=10101

13=1101

9=1001

3=11

40=101000

4=100

 

Теперь собственно сами действия:

а)

  10101

 + 1101

100010

 

б)

 10101

-  1101

   1000

 

в)

     1001

     *   11

     1001

+1001 

  11011

 

г)

 101000 |100

-100        | 1010

      100

     -100

            0

 

ответ:

а)100010

+ 0 -
Mens
11 авг. 2014 г., 3:44:18 (9 лет назад)

а)

21_{10}=10101_2 13_{10}=1101_2

 

10101+1101=100010

 

  10101

    1101

100010

 

б)

21_{10}=10101_2\\ 13_{10}=1101_2

 

 10101-1101=1000

 

 10101

   1101

   1000

 

в)

9_{10}=1001_2 3_{10}=11_2

 

1001*11=11011

 

     1001

          11

     1001

   1001 

   11011

 

 

г)

  40_{10}=101000_2 4_{10}=100_2

 

 101000 /100=1010

 

 

Ответить

Другие вопросы из категории

Сообщение кодируется последовательностью флажков,поочередно поднимаемых и опускаемых сигнальщиком.Передавая сообщение,сигнальщик поднимал флажки 3

раза.Сколько бит информации содержалось в переданном сообщении,если в набор сигнальщика входило 16 флажков???(С объяснением пожалуйста)

написать в программе паскаль
Запишите значение переменной s, полученное в результате работы следующей программы.

Var s,k: integer;

Begin
s:=0;

for k:=4 to 10 do

s:=s+11;

write(s);

End.

Читайте также

Выполнить сложение в двоичной системе счисления: 110101+10101, 11010+11001

Выполнить умножение в двоичной системе счисления: 110101+10101, 11010+11001

1. Назовите преимущества и недостатки двоичной системы счисления по сравнению с десятичной.

2. Какие двоичные числа соответствуют следующим десятичным числам: 128;256;512;1024?
3. Чему в десятичной системе равны следующие двоичные числа: 1000001; 10000001; 100000001; 1000000001?
4. Переведите в десятичную систему следующие двоичные числа: 101; 11101; 101010; 100011; 10110111011.
5.Переведите в двоичную систему счисления следующие двоичные числа: 2; 7; 17; 68; 315; 765; 2047.
6.Выполните сложение в двоичной системе счисления:11+1; 111+1; 1111+1; 11111+1.
7.Выполните умножение в двоичной системе счисления: 111*10; 111*11; 1101*101; 1101*1000.

Выполнить сложение в восьмеричной системе счисления 238+758 результат представить в двоичной системе счисления Выполнить сложение в

шестнадцатеричной системе счисления 1416+3В16. результат представить в двоичной системе счисления

Перевести число 173 из десятичной системы счисления в двоичную. Перевести число 110111011из двоичной системы счисления в десятичную. Записать

представление числа -115 в однобайтовой ячейке. Выполнить сложение в двоичной системе счисления: 110101+10101, 11010+11001 Выполнить умножение в двоичной системе счисления: 110101+10101, 11010+11001

Сколько единиц в двоичной записи числа 195? Сколько единиц в двоичной записи числа 173? Как представлено число 25 в двоичной системе счисления? Как

представлено число 82 в двоичной системе
счисления? Как представлено число 263 в восьмеричной
системе счисления?



Вы находитесь на странице вопроса "Выполните в двоичной системе счисления следующие арифметические операции: а)21+13 б)21-13 в)9*3 г)40/4", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.