Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

помогите написать задачу на с++

5-9 класс

Хулиганы Первый
и Второй очень не любят доску почёта своей школы. Поэтому они решили наглым
образом украсть оттуда школьную стенгазету, сделанную отличниками, и порвать на
части. Первый хулиган брал кусочек газеты и рвал его на 4 части, а Второй
хулиган – на 7. Однако очень скоро дежурные нашли N кусочков этой
газеты. Им стало интересно, все ли кусочки они нашли. Помогите им.

ХарлиКвин 04 дек. 2014 г., 4:51:16 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Софья762014
04 дек. 2014 г., 5:49:46 (9 лет назад)

Вот, правда немного запутано - не стал задумываться об элегантности кода. Алгоритм, вроде как, нашёл (N-1/b). 

#include <iostream>
using namespace std;
int main()
{
int n, b=3, x;
start:
setlocale (LC_ALL, "Russian");
cout << "Введите число собранных кусочков: ";
cin >> n;
x=n-1;
if (x%b==0)
cout << "Yes" << endl;
else
cout << "No" << endl;
goto start;
system ("pause");
}

+ 0 -
Desik993
04 дек. 2014 г., 7:26:47 (9 лет назад)

программу на c++

Ответить

Другие вопросы из категории

ПОМОГИТЕ!!! ЛЮДИ!!!!!!!!!!

сообщение записано 16-битной кодировке Unicode и содержит 768 символов. За сколько минут будет передано данное сообщение по каналу со скоростью 3 Кбит/с?

Для записи текста использовался 64-символьный алфавит. Ка-

кой объём информации в байтах содержат 10 страниц текста,
если на каждой странице расположено 32 строки по 64 симво-
ла в строке?

Читайте также

Помогите написать сочинение на тему:

"Почему я хочу работать с компьютером"

Сама написать не могу, фантазии нет, помогите

PASCAL. нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если рОЧЕНЬ нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если решиш - проси

что угодно, помогу)Вот задача - Под конец учебного года ученики 11 класса решали понять у кого же из них будет самый высокий средний балл ? Известно , что - в классе учится 14 учеников, - Сумма всех средних баллов аттестата = 100.Известно также , что первый ученик имел средний балл, который составляет 1/ 12 суммы всех средних баллов. Второй ученик - на 0,15 % больше, чем первый ученик , но на 1,75 % меньше , чем третий ученик . Средние баллы аттестатов двух сестер были равными среднему арефметичному оценок вышеупомянутых учеников , разделенном на 1.5 . Четвертый ученика на конец года имел такой же балл , как и первый ученик , но на 5% меньше , а остальные ученики - имели равные баллы .Какой средний балл на конец года получил каждЫй?

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.






Помогите решить задачу на языке программирования в Turbo Pascal, плиз Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он

увеличивал пробег на 10% от пробега предыдущего дня. Определить: а) ежедневное увеличение пробега лыжника за третий, четвёртый, ..десятый день тренировок; б) средний путь лыжника за первые 8 дней тренировок; в) сколько дней он будет бегать менее, чем по 15 км; г) в какой день суммарный пробег за все дни превысит 90 км.



Вы находитесь на странице вопроса "помогите написать задачу на с++", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.