Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

В массиве L(10) найти среднее арифметическое последних пяти элементов

10-11 класс

Nikitamelnikov3 14 июня 2014 г., 1:42:16 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Елезовета
14 июня 2014 г., 4:18:06 (9 лет назад)

uses crt;
var L:array [1..10] of real;
i,k:integer; sr:real;
begin
clrscr;
randomize;
for i:=1 to 10 do
begin
L[i]:=random(100)-50;
write(L[i],' ');
end;
k:=1;
sr:=0;
for i:=5 to 10 do
begin
sr:=(sr+L[i])/k;
k:=k+1;
end;
writeln;
write('srednee arifm.=',sr);
end.

Ответить

Другие вопросы из категории

Читайте также

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного

числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

Помогите исправить программу. Она должна вычислять среднее арифметическое всех чисел в массиве меньших 50. Вот программа:

Program Zadacha;
Uses crt;
var a:array[1..1000] of integer;
c,i,n,s :integer;
s1: real;
begin;
clrscr;
writeln("Введите размерность массива);
readln(n);
writeln('Введите массив');
for i:=1 to n do
begin a[i]:=random(100);
if a[i]<50 then begin inc(c); s:=s+a[i];end;s:=s+a[i];s1:=s/N;
writeln('Массив A:');
for i:=1 to N do write(a[i]:4);
writeln;
writeln('Среднее арифметическое равно=',s1);
end;
end.

Сделать следущие задачи на языке pascal abc

#2. Ввести В. Если В<10, выдать на печать 2*В. Если В>=10, вычислить и напечатать значения функции y=x²-x+tg(1/B+x) для значений x, изменяющихся от –3 до 1, с шагом 0,1.
#3. Ввести массив целых чисел Х(n). Найти среднее арифметическое значений элементов массива, не принадлежащих интервалу [-2;2]. Если среднее арифметическое значение>2, заменить значения первого и последнего элементов на 1, в ином случае – на 0. Массив распечатать.
#4. Ввести массив А(n). Найти сумму положительных элементов массива, исключая при этом те элементы, которые кратны трём. Полученной суммой заменить элементы 2-ой половины массива. Массив отпечатать.



Вы находитесь на странице вопроса "В массиве L(10) найти среднее арифметическое последних пяти элементов", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.