Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Создать програмку для этих двумерных массивов: 1 0 1 0 1 0... 1 0 1 0 1 0... 1 0 1 0 1 0... 1 1 1 1 1 1...

5-9 класс

.

0 0 0 0 0 0....

1 1 1 1 1 1....

0 0 0 0 0 0....

0 1 0 1 0...

1 0 1 0 1....

0 1 0 1 0....

1 0 1 0 1....

Помогите пожалуйста! Буду очень благодарна! ;)))

малика864 10 сент. 2013 г., 7:55:08 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Olegroy
10 сент. 2013 г., 9:57:49 (10 лет назад)

program zadacha_1;
const i=10;
      j=10;
type mymatrix = array[1..i,1..j]of byte;
      var k,n:integer;
          a:mymatrix;
begin
for k:=1 to i do begin
for n:=1 to j do begin
if (n mod 2=1) then a[k,n]:=1
else a[k,n]:=0;
write(a[k,n]:1);
end;
writeln;
end;
end.

 

Это для 1 случая

 

program zadacha_2;
const i=10;
      j=10;
type mymatrix = array[1..i,1..j]of byte;
      var k,n:integer;
          a:mymatrix;
begin
for k:=1 to i do begin
for n:=1 to j do begin
if (k mod 2=1) then a[k,n]:=1
else a[k,n]:=0;
write(a[k,n]:1);
end;
writeln;
end;
end.

 

Это для 2 случая

 

program zadacha_2;
const i=10;
      j=10;
type mymatrix = array[1..i,1..j]of byte;
      var k,n:integer;
          a:mymatrix;
begin
for k:=1 to i do begin
for n:=1 to j do begin
if (n mod 2=1) and (k mod 2=1) or (n mod 2=0) and (k mod 2=0) then a[k,n]:=1
else a[k,n]:=0;
write(a[k,n]:1);
end;
writeln;
end;
end.

 

Это для 3 случая




Ответить

Другие вопросы из категории

Когда сломался компьютер, его хозяин сказал: "Оперативная память не могла выйти из строя". Сын хозяина компьютера предположил, что сгорел процессор, а

жесткий диск исправен. Пришедший специалист по обслуживанию сказал, что, скорее всего, с процессором все в порядке, а оперативная память неисправна. В результате оказалось, что двое из них сказали все верно, а третий - все неверно. Что же сломалось?

а) оперативная память

б) процессор

в) винчестер

г) процессор и оперативная память

задание вот: зачеркните лишнее слово присуствие в каждой строке. 1) щука карась окунь рак 2) ромашка ландыш сирень

колокольчик

3) Саша Лена Коля Маша Егорова

4) ветка листок яблоко цветок птичка

5) заяц волк кабан лось овца

6) ухо лицо нос язык глаз

7) рысь медведь тигр лев кошка

8) шайба коньки качели клюшка

9) гусь лебедь павлин курица кролик

10) пот потолок потливый запотевший

11) горе нагорный горевать горемыка

12) тибет кавказ альпы байкал

13) Россия Франция Петербург Китай

14) Африка индия австралия южная америка

15) диван кровать тетрадь шкаф парта

16) дряхлый старый изношеный маленький ветхи

17) молоко сыр сливки сметана сало

18) подлежащее глагол дополнение определение

19) пять пятерка пятерня

20) четырехуголник четыре четверка

Помогите пожалуйста!

В чем заключается отличие между рабочей группой и доменом?Какие преимущества дает объединение компьютеров локальной сети в домен?

Придумайте загадки для понятий

телефон
стол
дискета
мышь
записная книжка

Читайте также

1) составить программу , которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный

2-ая Составить программу , которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми
язык паскаль

Помогите пожалуйста решить правильно и подробно 2 задачи по информатике: 1.Исправьте неточности в описании двумерного массива: Var

A= array[1..n,1..m] of integer;

2. Вставьте пропущенные определения:

… … двумерных массивов каждая строка заключается в дополнительную пару круглых скобок:

const a:mas= ((2,3,1,0),
(1,9,1,3),
(3,5,7,0));

даны два двумерных массива А и Б создать третий двумерный массив из максимальных элементов массивов А и Б как я понял нужно сравнить первый элемент

первого и 1 эл второго массива а затем использовать их для создания третьего


Пожалуйста помогите создать какую нибудь полезную программу на паскаль , срочно нужно до понедельника, чтобы в этой программе были все темы за 8 класс,

read.writeln.else.to.if и тд которые сможете
Вот пример идеи для программы, в академию поступают какое то количество учеников, нужно написать сколько учеников сдали документы, сколько пришли на экзамен, и сколько учеников кто прошло и не прошло
возможно не возможно создать программу на этой идее, тогда прделагайте свои со своими программами , пожалуйста помогите!



Вы находитесь на странице вопроса "Создать програмку для этих двумерных массивов: 1 0 1 0 1 0... 1 0 1 0 1 0... 1 0 1 0 1 0... 1 1 1 1 1 1...", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.