Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1) Определить средние арифметические элементы с чётным индексом и среднее арифметическое с нечётным индексом.

5-9 класс

Wwwapsuhppna38 12 июля 2014 г., 22:40:34 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vikusya212
13 июля 2014 г., 1:35:45 (9 лет назад)

uses crt;
const
     N=30;
var mas:array[1..N] of integer;
     i,sum1, sum2,k1,k2:integer;
     sr1,sr2:real;
beginfor i:=1 to N do
    readln(mas[i]);
for i:=1 to N do
    if i mod 2=0 then
    begin
         sum1:=sum1+mas[i];
         inc(k1);
    end
    else
    begin
         sum2:=sum2+mas[i];
         inc(k2);
    end;
writeln;
sr1:=sum1/k1; writeln('С четными индексами: ',sr1);
sr2:=sum2/k2; writeln('С нечетными индексами: ',sr2);
end.

Ответить

Другие вопросы из категории

подсчитайте,используя алфавитный подход к измерению информации ,сколько бит информации содержится в тексте,заключенном в кавычки:"кодирование информации с

помощью знаковых систем". учесть,что между словами ставится один пробел и для кодирования информации используется кодировка windows CP1251(таблица кодировки содержит 256 символов)

Нужно описать блок-схему (прикреплена к заданию) на языке паскаль.

*Если нужна задача.
Дано:
а, b, c - ввод.
min-?

Читайте также

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.
5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.
6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.
б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.
напишите хоть какое нибудь нужно к завтрому срочно

составьте программу,которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10,затем элементы с четными индексами удваивает, а

элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массивы.



Вы находитесь на странице вопроса "1) Определить средние арифметические элементы с чётным индексом и среднее арифметическое с нечётным индексом.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.