Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Даны два массива A(N) и B(N), где N<=15. Найти номер 1-ого нуля массива А и составить массив С(N), где каждый элемент массива С[i]= min(A[i],B[i])

10-11 класс

до найденного номера. Вывести на печать номер нуля, массива С и сообщение, если нуль не найден.

написать программу в Паскале.

спасибо

Axmadullin98 17 окт. 2016 г., 6:58:41 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nika29502
17 окт. 2016 г., 8:53:12 (7 лет назад)

uses crt;
var n,nullindex,i:integer;
a,b,c:array[1..15] of integer;
begin
writeln('N?');
read(n);
writeln('Введите элементы 1-го и 2-го массива.');
for i:=1 to n do
read(a[i]);
for i:=1 to n do
read(b[i]);
nullindex:=0;
for i:=1 to n do
if a[i]<>0 then
c[i]:=min(a[i],b[i])
else
begin
nullindex:=i;
break;
end;
if nullindex=0 then
writeln('Элемент не найден.')
else
begin
writeln(nullindex);
for i:=1 to nullindex-1 do
write(c[i],' ');
end;
end.

Ответить

Другие вопросы из категории

Читайте также

1.Даны два массива: А(5) и В(5). Сформируйте из них массив С,предварительно определив его длину,включая попеременно из массива А положительные

элементы, а из массива В -нечетные по значению.Выведите на экран массивы А,В,С.

2.Информация о площадях и средней урожайности хранится в массиве,где каждый элемент с четным индексом - засеянная площадь, а с нечетным - урожайность.Определите и выведите на экран кол-во собранной пшеницы и среднюю урожайность.

Помогите пожалуйста!

Даны два массива А и В, состоящие из 6 элементов.

Объединить два массива в один массив с чередованием элементов исходных
массивов. Вывести новый массив.
паскаль.

Добрый день. Помогите пожалуйста решить две задачи... №1 Дан массив из 25 элементов,найти сумму 4-х наибольших и 4-х наименьших э

лементов. Результат распечатать в виде:

Сумма наибольших=

Сумма наименьших=

№2

Даны два массива по 30 элементов. Найти среднее арифмитическое для элементов 1-го массива,номера которых больше номера минимального элемента 2-го массива

Заранее спасибо

Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)

и В(3*3). Вывести на экран тот из них, у которого меньше сумма элементов главной диагонали.

17.Дан массив А(3*4). Заменить все отрицательные элементы на противоположные.



Вы находитесь на странице вопроса "Даны два массива A(N) и B(N), где N&lt;=15. Найти номер 1-ого нуля массива А и составить массив С(N), где каждый элемент массива С[i]= min(A[i],B[i])", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.