Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Поменяйте между собой значения двух переменных X,Y, не используя дополнительной переменной.

5-9 класс

Coolcool03 23 июля 2014 г., 7:45:48 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
жеккаа
23 июля 2014 г., 8:16:43 (9 лет назад)

var
x,y:real;
begin
readln(x);
readln(y);
x:=x+y;
y:=x-y;
x:=x-y;
writeln(x,' ',y)
end.

Ответить

Другие вопросы из категории

Помогите решить логическую задачу

Мальчики Никита,Саша и Руслан учатся в разных школах.Они встретились после урока информатики, на котором каждый из них познакомился с одной из операционной системой :Windows,MacOs, и Linux. С какой системой познакомился каждый мальчик если известно что в школе на компьютерах установлены операционные системы: Windows и linux,Саша:Windows и MacOs. Известно что в школе у Руслана одна операционная система с логотипом которой является пингвин.
С объяснением пожайлуста

Читайте также

написать команды для обмена значениями 2 переменных a и b не используя дополнительную переменную определить сколько полных часов(h) и полных

минут(m)прошло с начала суток до того момента (в первой половине дня) когда часовая стрелка повернется на (f) градусов (от 0 до 360)

сделать ввиде алгоритма

1.Вставьте пропущенные слова в описании массива А, элементами которого являются целые числа. А: _________________[1..100] of ______________.

2. Опишите массив для хранения зарплаты за каждый месяц. Зарплату считать целым числом.

3.Опишите: a)Переменную В для массива, состоящую из 8 символов. b)Переменную MAS для массива, состоящего из 100 вещественных чисел. c)Переменную DAY для массива, состоящего из 30 целых чисел, причем номер первого элемента массива должен быть равен 5

.4. Пусть А : array [1..10] of integer. Напишите операторы, соответствующие следующим действиям: a. Третий элемент массива сделать равным 5. b. Вывести на экран 7-й элемент массива. c. Ввести значение 1-го элемента массива. d. Вычислить сумму 1,2 и 3-го элементов массива.

5. Пусть А : array [1..15] of real. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Вычислить сумму всех элементов массива (используйте цикл).

6. Пусть C : array [1..10] of integer. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Вывести на экран все элементы массива.

7. Пусть А : array [1..15] of real. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Поменять местами первый и последний элементы массива.

8. Пусть В : array [1..20] of integer. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Заполнить массив случайными числами из интервала [-24;37].

помогите какие знаете................ прошу помогите плиззз.......................

Решить задачи, составить программы:
1.Найти сумму цифр целого четырехзначного числа, и определить число,
цифры которого записаны в обратном порядку по отношению к исходному.
2.По введенному с клавиатуры аргументу вычислить значение функции.
3.Поменять местами значения двух переменных.
4. Написать программу ввода четырех чисел и вычисления их среднего арифметического.
5. Написать программу для вычисления дискриминанты квадратного уравнения.
6.Из железной полосы длиной L метров нужно изготовить обруч. На
соединение концов уходит D метров полосы. Написать программу вычисления
радиуса обруча.
7.Найти площадь конца, по введенным внешним и внутренним радиусам.
8.Найти расстояние между двумя точками по их координатам



Вы находитесь на странице вопроса "Поменяйте между собой значения двух переменных X,Y, не используя дополнительной переменной.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.