Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В массиве из 10 вещественных чисел вычислить среднее арифметическое массива, стоящих левее максимального. Составить программу на языке паскаль.

10-11 класс

Пожалуйста очень надо.

СИБУНА 24 июля 2015 г., 10:29:54 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jamily1
24 июля 2015 г., 12:04:21 (8 лет назад)

uses crt;
var
  a:array [1..10] of integer;
  i,max,k,n:integer; sr:real;
begin
  clrscr; randomize;

  writeln('Массив:');
  for i:=1 to 10 do
  begin
    a[i]:=random(100);
    write(a[i],' ');
  end;
  writeln;
  max:=a[1];
  for i:=1 to 10 do
    if a[i]>max then
    begin
      max:=a[i];
      n:=i;
    end;
  writeln('Максимальный элемент массива: ',max);
  for n:=n+1 to 10 do
  begin
    sr:=sr+a[n];
    k:=k+1;
  end;
  write('Среднее чисел, стоящих левее максимального: ',(sr/k));
end.

Ответить

Другие вопросы из категории

Cot takoe dvoicnoe cislo
Мне надо решить задачу по информатике в программе Pascal или на листочке.

Помогите пожалуйста решить

Задача№1(Линейный алгоритм)
Составить и выполнить программу, задав входные данные самостоятельно

Вычислить сторону,площадь (S=d2/2) и периметр квадрата, если если известна его диагональ d.

решите уравнение: 12x+23x=41x
Составить программу в PASCAL.

1. В последовательности чисел подсчитать произведение чисел, кратных 3.

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

Составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива. Заполнение массива элементами

организовать путем ввода с клавиатуры. В одномерном массиве из N натуральных чисел вычислить сумму удвоенных четных чисел.

В одномерном массиве B, состоящем из 20 вещественных чисел, найтинаибольший элемент и указать его номер в массиве.

Составить схему алгоритма и программу на языке программированияBasic для решения задачи по обработке одномерного массива.



Вы находитесь на странице вопроса "В массиве из 10 вещественных чисел вычислить среднее арифметическое массива, стоящих левее максимального. Составить программу на языке паскаль.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.