Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

дано положительное число с. для каждого значения х найти такое наибольшее к , при котором х^к не превышает заданное с. операцию возведения в степень не

10-11 класс

использовать

Maxx144 18 апр. 2016 г., 17:01:52 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
1f2f3f4fasdf
18 апр. 2016 г., 18:04:29 (8 лет назад)

var c, x, count: integer;
begin
    write('Введите c, x: '); readln(c, x);
    count := 1;
    while x <= c do begin
        x := x * x;
        inc(count);
    end; 
    writeln('x^', count, ' <= ', c, ' => k = ', count);
end.

Ответить

Другие вопросы из категории

При

сохранении данных в памяти компьютера минимальным объектом манипулирования
является:
1 ) символ

Метеорологическая станция ведет наблюдение за температурой воздуха. Считается, что температура должна быть представлена целым числом. При этом она не

может опускаться ниже минус 10 градусов и подниматься выше плюс 20 градусов. Каждое значение температуры записывается при помощи минимального возможного количества битов. За некоторый период станция сделала 100 измерений. Каков информационный объем результатов наблюдений?

Пожалуйста, с объяснением

Читайте также

ПОМОГИТЕ ПОЖАЛУЙСТА! ОЧЕНЬ НУЖНО!( 1)Осуществите циклический сдвиг компонент заданного вектора A(N) влево на одну

позицию, то есть получите вектор А = (a2 , a3 , ..., aN , a1 ).

2) Имеется последовательность чисел a1, a2 , ..., aN . Найти сумму первых из них, произведение которых не превышает заданного числа М.

СИ++. #include <stdio.h>

#include <conio.h>

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то

вычислить площадь этого треугольника. Даны два действительных положительных числа х и у. Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление). Составить программу, которая по выведенному номеру выполняет то или иное действие над числами.



Вы находитесь на странице вопроса "дано положительное число с. для каждого значения х найти такое наибольшее к , при котором х^к не превышает заданное с. операцию возведения в степень не", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.