Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Введите число от 1 до 1000.Определить сколько тысяч,сотен,десятков,единиц.Заранее спасибо

5-9 класс

Ilp98 25 июня 2014 г., 21:43:06 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sermik
26 июня 2014 г., 0:08:56 (9 лет назад)

var a:integer;

begin

readln(a);

writeln(a mod 10,' edinic');

a:=a div 10;

writeln(a mod 10,' desyatkov');

a:=a div 10;

writeln(a mod 10,' soten');

a:=a div 10;

writeln(a,' tisyach');

end.

Ответить

Читайте также

Помогите написать программу на паскале "Ввести число от 0 до 24 и вывести фразу «Доброе утро», «Добрый день», «Добрый вечер», «Спокойной ночи» в

зависимости от времени суток. Пример: Введите число от 0 до 24: 12 Добрый день!"

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

Задание 4.Составте программу ,выводящую на экран числа от 1 до 10 , по одному числу в строке.

Задание 5.Дополните программу из задания 4 так , чтобы на экран выводились числа от 1 до 10,а также квадраты и кубы этих чисел в следующем виде:
1 1 1
2 4 8
3 9 27
... ... ...
10 100 1000

ПОМОГИТЕ ПОЖАЛУЙСТА,ЗАДАНИЕ 4 ПИСАТЬ НЕ НУЖНО !ПОСТАВЛЮ ЛУЧЩИЙ ОТВЕТ И "СПАСИБО"

2) Даны числа от 5 до 78. Заменить все числа кратных 11 на квадрат этого числа.

3) Даны числа от 1 до n. Найти сумму чисел кратных 5, но не кратных 7.
Помогите пожалуйста!!!)))))



Вы находитесь на странице вопроса "Введите число от 1 до 1000.Определить сколько тысяч,сотен,десятков,единиц.Заранее спасибо", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.