Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дана последовательность из N (2<=N<=100000) различных чисел.

10-11 класс

Выписать в возрастающем порядке все целые числа находящиеся в интервале от минимального до максимального значения элементов этой последовательности, которые не находятся в данной последовательности.

олесясушкова 26 марта 2017 г., 4:22:23 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Настюша1112
26 марта 2017 г., 7:21:19 (7 лет назад)

var
  i,i_beg,i_end,k:longint;
  p:set of longint;
begin
  Writeln('Вводите целые числа большие двух, конец ввода по числу 0');
  i_beg:=1000000; i_end:=0;
  repeat
    Read(k);
    if k<>0 then
    begin
      if i_beg>k then i_beg:=k
      else if i_end<k then i_end:=k;
      Include(p,k)
    end
  until k=0;
  Writeln('Числа, не входящие в последовательность:');
  for i:=i_beg to i_end do
      if not (i in p) then Write(i,' ')
end.

Тестовое решение:
Вводите целые числа большие двух, конец ввода по числу 0
6 12 9 14 10 19 17 11 7 0
Числа, не входящие в последовательность:
8 13 15 16 18


Ответить

Другие вопросы из категории

Написать программу, которой передаются координаты точки (x,

y) и которая определяет, попадает ли точка в заштрихованную область на рисунке,
который соответствует Вашему варианту. Попадание на границу области считать
попаданием в область.(VBA)

информатика

нужно
срочно
ваще
резко
капец

Программы, являющиеся основными программными комплексами вычислительной системы:

1) операционные системы тестовые и диагностические программы

2) антивирусные программы

3) командно-файловые процессоры

Читайте также

Дается последовательность из N чисел. Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных
Первая строка входного файла содержит целое число N (1 <= N <= 100000). В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.

Ввести с клавиатуры три числа (x,y,z). Если x<y<z, то все числа удвоить.

Если z<y<x, то максимальное число возвести в квадрат. Если числа не
удовлетворяют ни одному из условий – обнулить их.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

Помогите пожалуйста)) Паскаль. Дана последовательность из 9

чисел. Вычислить произведение положительных
элементов последовательности

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива



Вы находитесь на странице вопроса "Дана последовательность из N (2&lt;=N&lt;=100000) различных чисел.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.