Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Последовательность Фибоначчи образуется так:

5-9 класс

первый и второй члены
последовательности равны 1, каждый следующий равен сумме двух предыдущих (1, 1,
2, 3, 5, 8, 13, ...). Найти
сумму
всех чисел в последовательности Фибонач­чи, которые не
превосходят 1000


SonuaGeydel 07 апр. 2017 г., 19:52:49 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Wwwgirls
07 апр. 2017 г., 21:29:06 (7 лет назад)

Var a,a1,a2:integer;
Begin
a1:=1;   
     while(a<1000) do begin
  a:=a1+a2;
a2:=a1;
a1:=a; 
writeln(a)   end;
End.

Получились числа:

+ 0 -
LeraZhurunova
07 апр. 2017 г., 23:37:26 (7 лет назад)

В Паскале

+ 0 -
Dashkalol
08 апр. 2017 г., 1:16:31 (7 лет назад)

в паскале?

+ 0 -
миша1997
08 апр. 2017 г., 2:05:56 (7 лет назад)

Да-, именно в Паскале)

Ответить

Читайте также

Напишите программу, которая в последовательности целых чисел находит сумму и количество чисел, кратных 17, или сообщает, что таких чисел нет. На вход

программы подаются целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (0 - признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введенные числа по модулю не превышают 300. Программа должна вывести сумму и количество чисел, кратных 17, или вывести NO, если таких числе в последовательности нет

Числа Фибоначчи строятся следующим образом: 1, 1, 2, 3, 5, …. В этой последовательности, начиная с третьего числа, каждый следующий член равен сумме двух

предыдущих. Получаем, что, например, шестое число равно 8, а десятое - 55.

Требуется написать программу, которая определяет, является ли заданное число числом Фибоначчи.

Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 9, или вывести NO, если таких чисел в последовательности нет.



Вы находитесь на странице вопроса "Последовательность Фибоначчи образуется так:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.