Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

cделать с помощью цикла repeat until

10-11 класс

Dana1511 04 июля 2014 г., 13:38:13 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kattsybbotina
04 июля 2014 г., 15:13:04 (9 лет назад)

var chislo:integer;
proverka:boolean;
begin 
 proverka:=true; 
    read(chislo);   
          repeat     
               if chislo=0 then                 //так как 0 не натуральное число
                 begin
                  proverka:=false; 
                  break;
                  end;
               if (chislo mod 3)>0 then         
                    begin             
                        proverka:=false;           
                        break;       
                    end     
                else chislo:=chislo div 3;   
           until(chislo=0);
    if proverka then WriteLn('Да')
    else WriteLn('Нет');
  readln;
end.

Ответить

Читайте также

Начав тренировки,спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Какой суммарный путь

пробежит спортсмен за 7 дней? Составить программу в паскале помощью цикла repeat.

Написать программу в Pascal ABC чтобы полностью работала, которая ввод данных

в одномерный целочисленный массив осуществляет посредством цикла WHILE…DO, а вывод - REPEAT…UNTIL (в скобках указана размерность
массива).



Вы находитесь на странице вопроса "cделать с помощью цикла repeat until", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.