Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Паскаль. Помогите, пожалуйста)))

10-11 класс

Дан двумерный массив целых чисел. В каждом столбце найти количество элементов кратных a и b.

шитовегор 04 окт. 2014 г., 9:40:56 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vetalbuchnev
04 окт. 2014 г., 10:22:59 (9 лет назад)

листинги в приложении ниже

первый листинг - ищет кратность либо а либо б
второй листинг - по отдельности ищет

+ 0 -
валюха234
04 окт. 2014 г., 11:12:17 (9 лет назад)

const
  m = 5;
  n = 8;

var
  x: array[1..m, 1..n] of integer;
  i, j, a, b, k: integer;

begin
  write('Введите числа a,b: ');
  readln(a, b);
  Randomize;
  writeln(#13#10, 'Исходный массив');
  for i := 1 to m do
  begin
    for j := 1 to n do
    begin
      x[i, j] := Random(100) - 50;
      write(x[i, j]:5)
    end;
    writeln
  end;
  writeln('Количество элементов матрицы, кратных ', a);
  for j := 1 to n do
  begin
    k := 0;
    for i := 1 to m do
      if x[i, j] mod a = 0 then k := k + 1;
    write(k:5)
  end;
  writeln;
  writeln('Количество элементов матрицы, кратных ', b);
  for j := 1 to n do
  begin
    k := 0;
    for i := 1 to m do
      if x[i, j] mod b = 0 then k := k + 1;
    write(k:5)
  end;
  writeln
end.

Тестовое решение:

Введите числа a,b: 4 7

Исходный массив
  -16    3   26    4   46   -6  -31   21
  -35  -34   46   42   15  -26   -9    4
  -19  -47    8  -48   13   14   42  -46
   41  -10   13   45  -20   15   13  -44
   18  -11   23  -30   44  -36   -8  -42
Количество элементов матрицы, кратных 4
    1    0    1    2    2    1    1    2
Количество элементов матрицы, кратных 7
    1    0    0    1    0    1    1    2



+ 0 -
маргошка10
04 окт. 2014 г., 12:32:48 (9 лет назад)

Комментарий удален

+ 0 -
дмитрий28092002
04 окт. 2014 г., 14:58:24 (9 лет назад)

Отдельно а и б, вводимых с клавиатуры)

Ответить

Другие вопросы из категории

1)(A\/B)/\(C\/D)

2)Ã\/B->A

На международных соревнования по прыжкам в воду первые пять мест заняли спортсмены из Гремании,Италии,Китая,России и Украины.Еще до начала соревнований

эксперты высказали свои предположения об итогах:

1)Первое место займет китай,а украина будет третьей.

2)украина будет последней,а германия предпоследней.

3)германия точно будет четвертой,а первое место китай.

4)россия будет первой,а италия второй.

5)Нет,Италия будет пятой,а победит германия.

По окончании соревнований выяснилось,что каждый эксперт был прав только в одном утверждении.Какие места в соревновании заняли участники?

решите,составив логическую модель.

Помогите, пожалуйста!!

вывести на экран коды таблицы от 0 до 250 и их символы. выводить парами.

Помогите пожалуйста!!

составить программу нахождения числ равных 0 в таблице состоящей из 15 целых чисел на pascal (маасив)

Читайте также

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите пожалуйста :(((

Даны шесть монет, из которых одна фальшивая. Фальшивая монета отличается от настоящей монеты весом, причем она либо немного тяжелее, либо немного легче. Имея рычажные весы, определить ложную монету не более чем за три взвешивания.
Это в паскале надо)
Пожалуйста!!!!))))



Вы находитесь на странице вопроса "Паскаль. Помогите, пожалуйста)))", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.