Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

заполнить массивы: Y - 47 значений номеров элементов; A - 5 местоимений; X - 30 случайных чисел из интервала [-7;25]

10-11 класс

Распечатать массивы: Y,X - в строчку; A - в столбик

в qbasic....

САШУЛЬКА999 03 апр. 2017 г., 14:54:41 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
андрей03
03 апр. 2017 г., 15:41:30 (7 лет назад)

не знаю как в qbasic, но думаю из паскаля переведешь:

uses crt;
var
Y:array[1..47] of integer;
X:array[1..30] of integer;
A:array[1..5] of string;
i:integer;
begin
clrscr;
randomize;
for i:=1 to 47 do
Y[i]:=i;

A[1]:='OH';
A[2]:='OHA';
A[3]:='OHO';
A[4]:='OHИ';
A[5]:='ТЫ';

for i:=1 to 30 do
X[i]:=random(33)-7;

for i:=1 to 47 do
write(Y[i], ' ');
writeln();

for i:=1 to 30 do
write(X[i], ' ');
writeln();

for i:=1 to 5 do
writeln(A[i]);
end.

Ответить

Другие вопросы из категории

Что представляет собой информация, содержащая текст или числа

1) дискретные данные

2) непрерывные (аналоговые) данные

Презентация "Моя учеба в школе"

Максимум на 2 слайда?Что можно написать там?

Читайте также

Составить блок-схему на языке Паскаль.

Задача
Двумерный массив L задан при помощи генератора случайных чисел из интервала [+1,+5].
Подсчитайте произведение элементов данного массива, которые больше 10, но меньше 30

дан целостный массив из 30 элементов. элементы массива могут принимать целые значения от 0 до 100 опишите на русском языке или одном из языков

программирования алгоритм позволяющий найти и вывести номер элемента массива имеющего максимальное значение сре элементов массива которые делятся на 3 и кратны 5

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного

числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

Написать программу (в Pascal) и составить блок-схему по задаче: В двумерном массиве произвольной размеренности подсчитать количество элементов, равных

наибольшему элементу в этом массиве. Вывести значение наибольшего элемента.



Вы находитесь на странице вопроса "заполнить массивы: Y - 47 значений номеров элементов; A - 5 местоимений; X - 30 случайных чисел из интервала [-7;25]", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.