Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

в четырёхзначном числе найти общее количество троек и семёрок

5-9 класс

Danilas03 27 апр. 2013 г., 13:45:37 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Adamzhanovadin
27 апр. 2013 г., 15:40:15 (11 лет назад)

#include <iostream>
using namespace std;

int main()
{
    int n;
    do
      cin >> n;
    while (n<1000 || n>9999);
    int k = 0;
    while (n!=0)
    {
        k+=(n%10==3 || n%10==7) ? 1:0;
        n/=10;
    }
    cout <<k <<endl;
    return 0;
}

Ответить

Другие вопросы из категории

файл пушкин.doc хранится на жестком диске в каталоге поэзия который является подкаталогом каталога литература/ В таблице приведены фрагменты полного имени

файла:
А Б В Г Д Е
Литература С: Пушкин \ .doc поэзия
востановите полное имя файла и закодируйте его буквами ( запишите соотвествующую последовательность букв без пробелов и запятых)

Два брата - Петя и Вася - работают на одном компьютере. Однажды на жестком диске "поселился" вирус, который заразил некоторые файлы. По сведениям Пети,

таких файлов было не более десяти. По сведениям Васи - не более одиннадцати. Известно, что одно из утверждений истинно, а другое ложно. Сколько файлов было заражено?
Приведите свои рассуждения.

Помогите, пожалуйста, с заданием по информатике)

Задание находится на фото, во вложениях)
Заранее спасибо)
Только распишите все подробно

Читайте также

Ребятки!!!!ПОмогите пожалуйста очень срочно!!!! Дан файл f компоненты которого действительные числа.Найти сумму компонентов

файла.Результат поместить в файл g.

дан файл f компоненты которого являются целыми числамию Найти наибольший и наименьший из компонентов файла.результат поместить в файл g

ДАн файл f компоненты которого являются целыми числами найти количество чётных чисел среди компонентов.результат поместить в файл g

Дан файл F компоненты которого являяются целыми числами.записать в файл g все чётных числа файла f

Дан файл F компоненты которого являяются целыми числами переписать компоненты файла f в файл g,так чтобы в файле сначала шли отрицательные а потом положительные числа.

1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC

НА QBASIC!!!!!!!!!! 1)Для массива А. Найти количество положительных, сумму нечетных и произведение чисел, кратных В. Результаты расчетаа и

массив вывести на экран.

2)Для массива А опредилить сумму квадратов отрицательных элементов, произведение положительных элементов, нулевые-заменить числом 12. Результаты расчета и массив вывести на экран.

3)Известны данные о количестве осадков, выпавших за каждый день января. Найти общее число осадков, выпавших по нечетным числам месяца.

4)Известна стоимость каждого из 15 видов товаров. Напечатать номера тех видов товаров, которые имеют стоимость всех видов товаров.

5)Дан массив А, отсортировать его по возрастанию. Отсортированный массив вывести на экран.

6)Дан массив А, Отсортировать его по убыванию. Отсортированный массив вывести на экран.

решить любые 2 задачи, пожалуйста!!! или хотя бы одну в PASKALe

1. Найти те элементы массива, которые равны сумме двух своих соседей. Первый и последний элемент имеют только по одному соседу, поэтому искомыми быть не могут.
На вход программе сначало подается значение n<=100 – количество элементов в массиве. В следующей строке расположены сами элементы массива – целые числа, по модулю не превосходящие 10000. Выдайте значения искомых элементов массива в том же порядке, в каком они располагались во входных данных.

2. На вход программе подается последовательность чисел от 1 до 9, заканчивающаяся нулем. Всего будет введено не более 100000 чисел. Подсчитайте в этой последовательности количество единиц, количество двоек, количество троек и т.д. и выдайте результат. В выходных данных всегда должно быть 9 чисел.
3. Текст на английском языке запишите в массив a[1..1000] of char. Помимо английских букв в нем могут встречаться пробелы и знаки препинания. В массиве b [‘A’ ..’Z’’] of integer получите сведения о том, сколько и каких букв встречается в этом тексте. При подсчете строчные и прописные буквы не различать. На вход программе подается значение n<=1000 – количество символов в тексте. В следующей строке входных данных расположены сами символы (без разделителей). Выдайте 26 чисел – значения элементов массива b.
Пример

Входные данные
Выходные данные
12
Hello world!
0 0 0 1 1 0 0 1 0 0 0 3 0 0 2 0 0 1 0 0 0 0 1 0 0 0

4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу.
На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Выдайте количество искомых элементов массива.

5. В массиве, заполненным произвольными целыми числами, найдите два числа, произведение которых максимально. Вложенные циклы не используйте. На вход программе сначала подается значение n<=10000 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы – целые числа, по модулю не превосходящие 30000. Выдайте два искомых числа в порядке неубывания.
6. На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Распечатайте только те значения элементов массива, которые встречаются в нем ровно один раз. Элементы следует распечатывать в том порядке, в котором они встречаются в массиве.

1)найти количесво делителей натурального числа,сколько из них чётных? 2) дано натуральное число: найти две первые цыфры числа

верно ли,что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа,которые состоят из разных цыфр,а их сумма равна А(А вводится с клавиатуры)

4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры)



Вы находитесь на странице вопроса "в четырёхзначном числе найти общее количество троек и семёрок", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.