Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Сделайте программу, которая представляет временной отрезок в секундах в формате час., мин., сек.. Например, 136 секунд - это 0 час. 2 мин. 16 сек..

10-11 класс

Sashenka765 16 окт. 2013 г., 13:59:21 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nikita050297
16 окт. 2013 г., 16:40:14 (10 лет назад)

Пишу на C:
void myTime(){
   int time;
   scanf("%i", time);

   int hour = (int)time/3600;
   int min = (int)time/60;
   int sec = time-((hour*3600)+(min*60));

   printf("%i:%i:%i", hour, min, sec);
}

Ответить

Другие вопросы из категории

помогите пожалуйста решить задачу по информатике!!!

в заповедник выпустили z зверей. за год количество особей увличивается на определенный процент. Сколько зврей будет через определенное время?
1. условие задачи
2. математическая модель
3. список переменных с их расшифровкой
4. блок- схема алгоритма
5. программный код

Задача:

Сколько существует различных последовательностей из символов «плюс» и «минус», длиной ровно в пять символов?

10-11 класс информатика ответов нет
Решите в паскале В данной строке каждый символ с номером,

кратным K, заменить на
пробел.

Читайте также

Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию.

Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

Написать программу в Pascal, используя массивы.

Дано массив А[1..n]. Сделать программу которая выводит те элементы массива? индексы которых являются степени двойки
Желательно с обьяснением строк



Вы находитесь на странице вопроса "Сделайте программу, которая представляет временной отрезок в секундах в формате час., мин., сек.. Например, 136 секунд - это 0 час. 2 мин. 16 сек..", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.