Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Найти произведение x*n с помощью цикла не используя операцию умножения

5-9 класс

Gosha0804 06 мая 2014 г., 6:20:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Elili
06 мая 2014 г., 8:54:07 (9 лет назад)

program mult; var x, n, i: integer; begin write('Введите x и n через пробел'); readln(x, n); if n>0 then for i:=1 to n-1 do x:=x+x else for i=1 downto n do x:=x-x; writeln('x * n =', x) end.

Ответить

Другие вопросы из категории

1)Самоделкин решил собрать робота обладающего слухом,зрением и возможностью общаться посредством голоса. Какой набор гаджетов ему наиболее подошел бы?

А) веб камера. микрофон, динамики
Б) вай-фай- роутер.гусеницы, микрофон
В) микрофон, экран, веб - камера
г) навигатор, экран, динамики
ПОЖАЛУЙСТА, ПОМОГИТЕ
2) 1)Устройство ввода информации.
2) Процедура обновления программного обеспечения или элементов системного блока
3) устройство ввода графической информации
6) Устройство модуляции / демодуляции

Задачи

практикума по языку Паскаль. Условный
оператор.

Читайте также

решить любые 2 задачи, пожалуйста!!! или хотя бы одну в PASKALe

1. Найти те элементы массива, которые равны сумме двух своих соседей. Первый и последний элемент имеют только по одному соседу, поэтому искомыми быть не могут.
На вход программе сначало подается значение n<=100 – количество элементов в массиве. В следующей строке расположены сами элементы массива – целые числа, по модулю не превосходящие 10000. Выдайте значения искомых элементов массива в том же порядке, в каком они располагались во входных данных.

2. На вход программе подается последовательность чисел от 1 до 9, заканчивающаяся нулем. Всего будет введено не более 100000 чисел. Подсчитайте в этой последовательности количество единиц, количество двоек, количество троек и т.д. и выдайте результат. В выходных данных всегда должно быть 9 чисел.
3. Текст на английском языке запишите в массив a[1..1000] of char. Помимо английских букв в нем могут встречаться пробелы и знаки препинания. В массиве b [‘A’ ..’Z’’] of integer получите сведения о том, сколько и каких букв встречается в этом тексте. При подсчете строчные и прописные буквы не различать. На вход программе подается значение n<=1000 – количество символов в тексте. В следующей строке входных данных расположены сами символы (без разделителей). Выдайте 26 чисел – значения элементов массива b.
Пример

Входные данные
Выходные данные
12
Hello world!
0 0 0 1 1 0 0 1 0 0 0 3 0 0 2 0 0 1 0 0 0 0 1 0 0 0

4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу.
На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Выдайте количество искомых элементов массива.

5. В массиве, заполненным произвольными целыми числами, найдите два числа, произведение которых максимально. Вложенные циклы не используйте. На вход программе сначала подается значение n<=10000 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы – целые числа, по модулю не превосходящие 30000. Выдайте два искомых числа в порядке неубывания.
6. На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Распечатайте только те значения элементов массива, которые встречаются в нем ровно один раз. Элементы следует распечатывать в том порядке, в котором они встречаются в массиве.



Вы находитесь на странице вопроса "Найти произведение x*n с помощью цикла не используя операцию умножения", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.