Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дана двумерная матрица n на m.найти максимально отрицательное и разместить его в центре матрицы. Алгоритм и программа

10-11 класс

Qweqwe12 13 дек. 2013 г., 10:30:18 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Astan130698
13 дек. 2013 г., 12:50:08 (10 лет назад)

const m=5; n=4;
Var a:array[1..m,1..n] of integer; i,j,max:integer;
Begin
 randomize;
 for i:=1 to m do
   for j:=1 to n do a[i,j]:=random(201)-100;
 max:=0;
 for i:=1 to m do
   for j:=1 to n do
     if a[i,j]<max then max:=a[i,j];
 if max=0 then writeln('В матрице нет отрицательных элементов.')
  else a[(m div 2)+1,(n div 2)+1]:=max;
 for i:=1 to m do        //Вывод матрицы. Необязательно.
   begin
    for j:=1 to n do write(a[i,j]:4);
    writeln;
   end;
End.

Ответить

Другие вопросы из категории

Напишите программу пожалуйста

Определить полярные координаты точки, заданные декартовыми координатами (x,y) по формулам f=arctg(x/y), r=√x^2+y^2. При вычислении угла @ необходимо учесть, что значение х может быть равно нулю, а угол может находиться в различных четвертях.

Какое логическое выражение равносильно выражению : -(A+-B+C)

1)-А+В+-С
2)А^-В^С
3)-А+-В+-С
4)-А^В^-С

Читайте также

Ребят помогите программу дописать по vba: в общем нужно сделать матрицу с рандомными числами, найти наименьшее число в ней, и сделать другую матрицу на

порядок меньше, с вычеркнутым столбцом и строкой на пересечении которых находится наименьшее число из первой матрицы. Я нашел наименьшее число, а как дольше делать понять не могу.
Вот начало самой программы:
Sub laba9()
Dim N As Integer, a() As Integer, i As Byte, j As Byte, min As Integer, l1 As Integer, l2 As Integer
N = Val(InputBox("Введите размерность массива"))
ReDim a(N, N)
Sheets("Лист1").Select
Sheets("Лист1").Range("A1:AAA100").Clear
For i = 1 To N
For j = 1 To N
a(i, j) = Rnd * 100
Cells(i, j) = a(i, j)
Next j
Next i
min = a(1, 1)
l1 = 1
l2 = 2
For i = 1 To N
For j = 1 To N
If a(i, j) < min Then
min = a(i, j)
l1 = i
l2 = j
End If
Next j
Next i
End sub

№1 Дана действительная квадратная матрица порядка n. Найти произведение четных элементов.

№2 В данном одномерном массиве Х[1..n] найти сумму отрицательных элементов , кратных 7.

Дан двумерный массив

размерностью n х m,
заполненный случайными числами. Определить, есть ли в данном массиве строка,
содержащая больше положительных элементов,
чем отрицательных. Ответ: «Есть» или «Нет».
Если можно решите попроще, каждая отдельная операции через подпограмму



Вы находитесь на странице вопроса "Дана двумерная матрица n на m.найти максимально отрицательное и разместить его в центре матрицы. Алгоритм и программа", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.