Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Даны две дроби найти их сумму . (Паскаль)пожалуйста, срочно надо!

5-9 класс

Malisaalisa28 07 апр. 2014 г., 10:43:56 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Нютюсик
07 апр. 2014 г., 13:21:43 (10 лет назад)

Program DROB;
uses crt;
var
a, b, c, d: integer;
s: real;
   begin
   Write('Введите числитель a1 = ');
   Readln(a);
   Write('Введите знаменатель b1 = ');
   Readln(b);
   Writeln;
   Write('Введите числитель с2 = ');
   Readln(c);
   Write('Введите знаменатель d2 = ');
   Readln(d);
   S:=(a*d+b*c)/(b*d);
   Writeln;
   write('Сумма дробей s = ', s:0:3);
  
   readln;
end.    

+ 0 -
Dido10
07 апр. 2014 г., 15:40:45 (10 лет назад)

var
  n1, d1, n2, d2, m, n, d, nn, dd, nod: integer;
  r: double;

begin
  Writeln('Нахождение суммы двух простых дробей.');
  Write('Введите через пробел числитель и знаменатель первой дроби: ');
  Readln(n1, d1);
  Write('Введите через пробел числитель и знаменатель второй дроби: ');
  Readln(n2, d2);
  {Находим результат, как простую дробь}
  n := n1 * d2 + n2 * d1;
  d := d1 * d2;
  r := n / d;
  {Если дробь неправильная, надо исключить целое число}
  if n > d then begin m := n div d; n := n mod d end
  else if n = d then begin m := 1; n := 0; d := 1 end
  else m := 0;
  {Возможно числитель и знаменатель дроби могут быть частично сокращены}
  if n <> 0 then begin
    {ищем НОД числителя и знаменателя и делим их на него}
    nn := n; dd := d;
    while nn <> dd do
      if nn > dd then nn := nn - dd else dd := dd - nn;
    nod := nn;
    if nod <> 1 then begin n := n div nod; d := d div nod end;
  end;
  Write(n1, '/', d1, ' + ', n2, '/', d2, ' = ');
  if m > 0 then
    if n <> 0 then Writeln(m, ' ', n, '/', d, ' = ', r)
    else Writeln(m)
  else
    Writeln(n, '/', d, ' = ', r)
end.

Тестовые примеры:

Нахождение суммы двух простых дробей.
Введите через пробел числитель и знаменатель первой дроби: 25 5
Введите через пробел числитель и знаменатель второй дроби: 64 256
25/5 + 64/256 = 5 1/4 = 5.25

Нахождение суммы двух простых дробей.
Введите через пробел числитель и знаменатель первой дроби: 8 19
Введите через пробел числитель и знаменатель второй дроби: 154 221
8/19 + 154/221 = 1 495/4199 = 1.11788521076447

Нахождение суммы двух простых дробей.
Введите через пробел числитель и знаменатель первой дроби: 5 7
Введите через пробел числитель и знаменатель второй дроби: 12 42
5/7 + 12/42 = 1

Нахождение суммы двух простых дробей.
Введите через пробел числитель и знаменатель первой дроби: 1 5
Введите через пробел числитель и знаменатель второй дроби: 3 11
1/5 + 3/11 = 26/55 = 0.472727272727273





Ответить

Другие вопросы из категории

вставте пропущенные устройства.

Я включил компьютер и набрал на ... сочинение про свою семью. Затем я переписал с ... последние фотографии, добавил их к тексту и вывел сочинение на ... . После этого я прибавил громкость звука ... и стал играть в любимую игру, быстро двигая ... . Получив рекордный результат, я ввёл с ... своё имя и распечатал на ... список рекордсменов.

Читайте также

ПОМОГИТЕ ПОЖАЛУЙСТА!!!

Даны 2 числа.Найти их сумму,если числа равны,и найти их произведение,если числа не равны.Написать блок схему и составить программу на Паскаль.

Решите задачу в паскале пожалуйста,срочно надо.

Найти количество отрицательных чисел из 20 случайных
использовать for и random

1)найти количесво делителей натурального числа,сколько из них чётных? 2) дано натуральное число: найти две первые цыфры числа

верно ли,что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа,которые состоят из разных цыфр,а их сумма равна А(А вводится с клавиатуры)

4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры)



Вы находитесь на странице вопроса "Даны две дроби найти их сумму . (Паскаль)пожалуйста, срочно надо!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.