Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дано целое число n. Выведите следующее за ним четное число. При решении этой задачи нельзя исп

5-9 класс

ользовать условную инструкцию if и циклы.

светуля20 13 янв. 2017 г., 8:52:56 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aika2006
13 янв. 2017 г., 9:36:07 (7 лет назад)

var
n,a:integer;
begin
write('Введите число: ');
readln(n);
a:=n mod 2;
writeln('Следующее четное число: ', n+2-a*1);
end.

Ответить

Другие вопросы из категории

Ребята помогите пожалуйста мне ????

Сосчитай сумму всех чисел в первой строке таблицы.

На сколько больше получится сумма чисел в строке , которая начинается с числа 2 ?

Расположите величины в порядке убывания :

1024 бита; 1000 байтов; 1 бит; 1 байт; 1 Кбайт.
Помогите пожалуйста!!!!

В олимпиаде по информатике приняли участие 1111002

мальчиков и 11002 девочек. Сколько всего мальчиков и девочек
участвовали в олимпиаде?

Читайте также

плз помогите.. составить программу на языке авс паскаль 1)напишите программу, которая считывает два целых числа a и b

и выводит наибольше значение из них. Числа - целые от 1 до 1000.

при решении задачи можно пользоваться только целочисленными арифметическими операциями +,-,*,//,%,=. нельзя пользоваться нелинейными конструкциями:ветвления, циклами, функциями вычисления модуля, извлечения квадратного корня., и условными функциями!!!!!!!

2) Дано целое число N. Выведите следующее за ним четное число. При решении задачи нельзя использовать условную инструкцию if и циклы!!

хотя бы формулу:) заранее спасибо)

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

В некоторой школе занятия начинаются в 9:00. Продолжительность урока —

45 минут, после 1-го, 3-го, 5-го и т.д. уроков перемена 5 минут, а
после 2-го, 4-го, 6-го и т.д. — 15 минут.

Дан номер урока (число от 1 до 10). Определите, когда
заканчивается указанный урок. Выведите два целых числа: время окончания
урока в часах и минутах. При решении этой задачи нельзя пользоваться
циклами и условными инструкциями. Напишите что нужно сделать (pascal)

С начала суток часовая стрелка повернулась на угол в градусов. Определите на какой угол повернулась минутная стрелка с

начала последнего часа. Входные и выходные данные — действительные числа.

При решении этой задачи нельзя пользоваться условными инструкциями и циклами. Напишите программу(Free Paskal), заранее спасибо!



Вы находитесь на странице вопроса "Дано целое число n. Выведите следующее за ним четное число. При решении этой задачи нельзя исп", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.