Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Задача по паскалю тип integer

5-9 класс

каких элементов в массиве больше положительных или отрицательных

Facebook104 27 авг. 2013 г., 23:11:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dombrowa2014
28 авг. 2013 г., 1:27:52 (10 лет назад)

var a: array [0..9] of integer;
    i, j: integer;
begin
     write('     ');
     for i := 0 to 9 do
     begin
          a[i] := random(51) - 25;
          writeln('[', i, '] => ', a[i]);
     end;
          for i := 0 to 9 do
     if (a[i] < 0) then 
       dec(j)
     else
         if (a[i] > 0) then
            inc(j);
     if (j > 0) then writeln('+ > -');
     if (j = 0) then writeln('+ = -');
     if (j < 0) then writeln('+ < -');
end.

Ответить

Другие вопросы из категории

Одномерный массив из 10 элементов с номерами от 10 до 20 заполнить случайным образом числами от 0 до 22. Все элементы массива,значения которых лежат между

10 и 20 включительно,увеличить в 5 раз.Вывести на экран монитора первоначальный и преобразованный массивы в столбик.

Помогите написать программу на Паскале. Найти

a_{n} и S арифметической прогрессии через цикл for.

Читайте также

надо решить задачу по паскалю) "Чтобы избавиться от простуды необходимо 20 таблеток колдрекса или 30 таблеток аспирина. Сколько порций эскимо можно

купить на эти деньги?"
напишите пожалуйста как составить это в паскале) буду благодарна:)

пожалуйста, помогите решить задачи по Паскалю!!!

1) Даны два числа. Составить алгоритм и перевести его на язык программирования, который меньшее из них возводит в квадрат, а большее оставляет без изменения,

ПОМОГИТЕЕ


Решите задачу по Паскалю пожалуйста!


Вы находитесь на странице вопроса "Задача по паскалю тип integer", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.