Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите пожалуйста с блоком схемы!

10-11 класс

Дана квадратная матрица порядка S. Обнулить из неё каждый третий столбец.В полученном массиве найти сумму чётных элементов.

Alina0798 16 нояб. 2014 г., 2:04:58 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lisiciya
16 нояб. 2014 г., 3:36:54 (9 лет назад)

const S = 6;
var i, j, sum: integer;
     a: array[1..S, 1..S] of integer;
begin
    for i := 1 to S do begin
        for j := 1 to S do begin
            if(j mod 3 = 0) then a[i, j] := 0
            else a[i, j] := random(15);
            if(a[i, j] mod 2 = 0) then sum := sum + a[i, j];
            write(a[i, j]:4);
        end;
        writeln;
    end;
    writeln('Сумма четных элементов: ', sum);
end.

Ответить

Другие вопросы из категории

Найдите наименьшее K, такое что K! делится на N без остатка. K!=1*2*3...*(K-1)*K

Форма входа данных : в первой и единственной строке дано число N (1= Формат выходных данных: Выведите наименьшее число K факториал которого делится на N.

Примеры A.in = 4 A.out = 4 A.in = 8 A.out = 4

Читайте также

Определить все простые двузначные числа. Есть предположение, что решается именно так, помогите пожалуйста составить блок-схему. Program

example14;

Var i:

integer; function prost(i: integer): boolean;

var j:integer;

begin prost := true; i:=abs(i); for j := 2 to (i div 2) do if (i mod j = 0) then prost := false; end;

begin for i := 10 to 99 do if prost(i) = true then write(i:5);

readln(i);

end.

Помогите ,пожалуйста,составить блок-схему. Program qqq; Var a:array[0…9] of byte; n,k: integer; j: byte; begin readln(n); for j:=0 to 9 do a[j]:=0;

while n>0 do begin k:=n mod 10; n:=n div 10; inc (a[k]); end; for j:=0 to 9 do if a[j].0 then writeln (j, a[j]); for j:=0 to 9 do if a[j]=0 then writeln(j); end.



Вы находитесь на странице вопроса "Помогите пожалуйста с блоком схемы!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.