Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите пожалуйста нужно в паскале

10-11 класс

Shishkina69 24 марта 2015 г., 17:38:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sergei14
24 марта 2015 г., 19:21:44 (9 лет назад)

var n,k:integer;
begin
readln(n,k);
write (k mod n);
end.

+ 0 -
Sasha4221
24 марта 2015 г., 20:57:00 (9 лет назад)


program name;//Имя программы
uses crt;//Запуск программы в консольном режиме НЕОБЯЗАТЕЛЬНО
var  people:integer; 
apple:integer;    
BEGIN     
write('Введите количество учеников: '); readln(people); //Ввод количество учеников
  write('Введите количество яблок: '); readln(apple);//Ввод количества яблок
    if apple/people < 1    
 then writeln('Каждому ученику достанется ', apple/people, ' яблок(а)')    
else writeln('Каждому ученику достанется ', trunc(apple/people), ' яблок(а)');     
write('В корзине останется ', apple - trunc(apple/people)*people, ' яблок(а)'); 
ReadKey;
end.

+ 0 -
Monsterhi
24 марта 2015 г., 21:27:56 (9 лет назад)

получилось?

+ 0 -
Gunay555
24 марта 2015 г., 23:15:10 (9 лет назад)

думаю как округлить значения яблок

+ 0 -
Ritama
25 марта 2015 г., 1:09:44 (9 лет назад)

получилось?

+ 0 -
Tanatatyana123
25 марта 2015 г., 3:59:01 (9 лет назад)

Да

+ 0 -
Khamzin2005
25 марта 2015 г., 5:13:38 (9 лет назад)

спасибо

Ответить

Другие вопросы из категории

Записать на языке «Паскаль»

программу, реализующую алгоритм работы кассира, выдающего покупателю сдачу
сумма «S» наименьшим кол-вом банкнот по 1000 , 500, 100, 50, 10 рублей.

Срочно, помогите!

Читайте также

помогите пожалуйста нужна программа Паскаль вот задача (При каждом переходе через волшебный мост мужик, имеющий b рублей, удваивает эту сумму за счет

капитала черта (а рублей), стерегущего этот мост, после чего он должен уплатить черту дань в размере с рублей. Процесс этот продолжается до полного разорения одного из участников.Сколько будет совершено переходов моста?). вот блок схема пожалуйста сроочноо

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)



Вы находитесь на странице вопроса "помогите пожалуйста нужно в паскале", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.