Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ПАСКАЛЬ!!!! составить алгоритм, находящий остаток от деления одного натур-го числа на другой( диф и мод не использовать)

5-9 класс

Миха32 31 янв. 2015 г., 22:26:13 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Georgekobuladze
31 янв. 2015 г., 23:35:49 (9 лет назад)

Можно использовать другие команды? Например Trunc?
Если да, то вот:
var i,j,n:integer;
s:real;
begin
readln(i,j);
s:=i/j;
n:=i-j*Trunc(s); {Функция Trunc выделяет целую часть}
writeln(n);
end.
Если нельзя пользоваться Trunc, то вот другое решение:
var i,j:integer;
s,m:real;
begin
readln(i,j);
m:=i/j;
s:=m;
while s>=1 do s:=s-1;
m:=m-s
;writeln(i-j*m;);
end.

Ответить

Другие вопросы из категории

ПОМОГИТЕ РЕШИТЬ ПОЖАЛУЙСТА! Заданы массивы A и B чисел (N=10) случайным образом. Сформировать новый массив, каждый элемент которого равен:

сумме этих массивов ; минимальную из соответствующих элементов этих массивов.

20 баллов СРОЧНО

Ста­тья, на­бран­ная на ком­пью­те­ре, со­дер­жит 16 стра­ниц, на каж­дой стра­ни­це 35 строк, в каж­дой стро­ке 64 сим­во­ла. Опре­де­ли­те ин­фор­ма­ци­он­ный объём ста­тьи в одной из ко­ди­ро­вок Unicode, в ко­то­рой каж­дый сим­вол ко­ди­ру­ет­ся 16 би­та­ми.

Что такое информатика?

Читайте также

1) составьте программу заполнения элементов массива [1..10 ] случайнымии целыми числами на отрезке [ 0;35 ] и вывода на экран нечетных элементов и

кратных числу 3.

2) составьте программу , которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 100 и выводит на экран среднее арифмитическое элементов массива

Найти алгоритм минимума из 3х целых чисел на паскале+ составить блок -схему.

ПОЖАЛУЙСТА,ХОТЯ БЫ НА ПАСКАЛЕ СОСТАВЬТЕ!

Проверочная работа<Линейные алгоритмы>

Составить программы для вычисления:

a) Среднего арифметического кубов двух целых чисел m и n.

Ответ дать с точность до трёх знаков после запятой.

б) Дано четырёхзначное число. Найти остаток от деления чисел образованных первыми двумя цифрами и последними двумя цифрами этого числа



Вы находитесь на странице вопроса "ПАСКАЛЬ!!!! составить алгоритм, находящий остаток от деления одного натур-го числа на другой( диф и мод не использовать)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.