Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано целое число Х и натуральное N. Составьте алгоритм вычисления Х^n. Напишите программу на Паскале.

5-9 класс

Tippoetta 26 мая 2014 г., 22:19:57 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Azerqadimov
26 мая 2014 г., 23:14:00 (9 лет назад)

var s,x,n,i:integer;

Begin

  read(x,n);

s:=1;

  for i:= 1 to n do

    s:=s*x;

  writeln(s);

End.

Ответить

Другие вопросы из категории

Читайте также

Составьте алгоритм вычисления суммы всех

натуральных чисел, не превышающих заданного натурального числа N.
Проверьте алгоритм трассировкой. Напишите программу на Паскале.

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

Вариант № 2 1)Подсчитать сумму квадратов всех отрицательных и четных чисел из 10 вводимых. 2) Даны натуральные числа от 35 до 87.

Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.

3)Дано целое число а и натуральное (целое неотрицательное) число n. Вычислить а в степени n, используя в программе лишь операцию умножения.

4)Введите последовательность из n целых чисел. Найти наибольшее из всех отрицательных чисел. Вывести его значение и порядковый номер.

5)Вычислите: 99-97+95-93+91-89+....+7-5+3-1.

6)Доказать (путем перебора возможных значений), что для любых величин А, В, С типа Boolean следующая пара логических выражений имеет одинаковые значения (эквивалентны): A OR (B AND C) и (A OR B) AND (A OR C).

Составить программы в Turbo Pascal. 1)Дано три точки A,B,C на числовой оси.Найти длинну отрезка AC и BC и их сумму. 2)Задано четыре целых числа

a,b,c,d.Выяснить произведение этих чисел больше 300? 3)Дано целое число ,если оно положительное,то прибавить к нему 1,а если отрицательное.то отнять от него 2.Вывести полученое число.



Вы находитесь на странице вопроса "Дано целое число Х и натуральное N. Составьте алгоритм вычисления Х^n. Напишите программу на Паскале.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.