Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите!!!!

10-11 класс

Прошу помогите, умоляю.........
Это Паскаль.....

MimOR 25 июля 2013 г., 9:57:02 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
StrifyKiro
25 июля 2013 г., 10:37:33 (10 лет назад)

type
    arr25 = array[1..25] of integer;

var
    a, b, c, d: arr25;
    i, a_n, b_n, c_n, d_n, sum_a, sum_b: integer;

procedure show(a: arr25; length: integer) ;
var
    i: integer;
begin
    writeln;
    for i := 1 to length do
        write(a[i], ' ');
end;

procedure fill(var a: arr25; length, min, max: integer) ;
var
    i: integer;
begin
    for i := 1 to length do
        a[i] := min + random(max - min + 1);
    show(a, length);
end;

function average(a: arr25; length: integer): real;
var
    i, sum: integer;
begin
    for i := 1 to length do
        sum := sum + a[i];
    average := sum / length;
end;

procedure sort(var a: arr25; length: integer);
var
    key, i, j: integer;
begin
   
    for i := 1 to length do
    begin
        key := A[i];
        j := i - 1;
        while (j >= 1) and (A[j] > key) do
        begin
            A[j + 1] := A[j];
            j := j - 1;
        end;
        A[j + 1] := key;
    end;
end;

begin
   
    fill(a, 4, 10, 50);
    fill(b, 10, 25, 38);
    fill(c, 25, 10, 38);
    fill(d, 15, 5, 60);
   
    writeln;
   
    writeln(average(a, 4) * average(b, 10));
   
    sort(c, 25);
    sort(b, 10);
   
    show(c, 25);
    show(b, 10);
end.

Ответить

Другие вопросы из категории

Написать программу на turbo pascal.

1.Вычислить значение факториала n! (P=1*2*...*n*N)..N=12
2.Найти сумму элементов заданного массива C[1..n]. Данные для ввода: n=7; C[1;2;3;-4;5;-6;7].
3.

Ребята помогите номер 8 решить

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

Помогите пожалуйста!) Напечатать программу в паскале......

Пожалуйста...Срочно...Завтра крайний срок сдачи...Помогите...

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

Задания за 9 класс. Ребят, помогите, пожалуйста. С Exel работать надо, на компьютере его нет (на windows 8 перешла), к тому же, честно говоря, не умею им

пользоваться. Добрые люди, пожалуйста, помогите :с Завтра сдавать :с



Вы находитесь на странице вопроса "Помогите!!!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.