Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Удалить из строки символы между 1 и последней *, если *<2, то вывести сообщение.

5-9 класс

вот программа, что не так?
var s:string; k1,k2,i:integer;
begin
writeln('введи строку');
readln(s);
k1:=pos('*',s);
for i:=1 to length(s) do
if s[i]='*' then k2:=i;
if (k1=0) or (k2=0) then writeln('нет ни одной *')
else if (k1<2) or (k2<2) then writeln('нет 1 звездочки')
else delete(s,k1,k2-k1+1);
write(s);
writeln;
readln;
end.
на 1 скрине просто удаляет *,а на 2 скрине выводит так...

Neckvic 26 дек. 2016 г., 19:53:45 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
FanatkaFilatova28
26 дек. 2016 г., 21:11:02 (7 лет назад)

var s:string; k1,k2,i:integer;
begin
writeln('введи строку');
readln(s);
k1 :=pos('*',s);
for i:=1 to length(s) do;
if s[i]='*' then k2 :=i;
if (k1=0) or (k2=0) then writeln('нет ни одной *')
else if (k1<2) or (k2<2) then writeln('нет 1 звездочки')
else delete(s,k1,k2-k1+1);
write(s);
writeln;
readln;
end. 

+ 0 -
Lapteva02
26 дек. 2016 г., 22:10:57 (7 лет назад)

var
  s:string;
  k1,k2,i:integer;
begin
writeln('введи строку');
readln(s);
k1:=pos('*',s);
for i:=k1+1 to length(s) do
  if s[i]='*' then k2:=i;
if (k1=0) then writeln('нет ни одной *')
  else if (k2=0) then
    writeln('нет 1 звездочки')
      else delete(s,k1,k2-k1+1);
write(s);
writeln;
readln;
end. 

Ответить

Другие вопросы из категории

Читайте также

Пользователь создал сообщение из 256 символов в кодировке Unicode, в которой каждый символ кодируется 16 битами. После редактирования информационный объём

сообщения составил 3072 бит. Определите, сколько символов удалили из сообщения, если его кодировка не изменилась.1)1002)643)324)16

Алфавит племени Мульти состоит из 32 символов. Члены племени используют в своей речи и письме только слова длиной 8 символов, причем все слова

начинаются или с символа А, или с символа О, или символа В, или с символа К, остальные буквы в слове могут быть любыми. Какое количество информации несет сообщение этого племени, состоящее из 20 символов?



Вы находитесь на странице вопроса "Удалить из строки символы между 1 и последней *, если *&lt;2, то вывести сообщение.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.