Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

В одну и ту же числовую переменную последовательно вводятся целые числа. Количесвто вводимых чисел заранее известно ( 0 - конец ввода). Определить

10-11 класс

количество чисел не кратных 5.

2004kirill 06 марта 2017 г., 23:16:45 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Agapa1982
07 марта 2017 г., 0:32:58 (7 лет назад)

На паскале:
Var x,k:integer;
Begin
k:=0;
Repeat
Readln(x);
If (x mod 5 = 0) and (x<>0) then inc(k);
Until x=0;
Writeln(k);
End.

Ответить

Читайте также

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.



Вы находитесь на странице вопроса "В одну и ту же числовую переменную последовательно вводятся целые числа. Количесвто вводимых чисел заранее известно ( 0 - конец ввода). Определить", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.