Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Разработать. Схему алгоритма, который запрашивает ввод целого числа в переменную В и выводит это число на экран. Отгладить алгоритм и проверить его прав

10-11 класс

ильность на числах 1;-5;256;10455

Serd2011 07 окт. 2013 г., 6:30:31 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
лена110704
07 окт. 2013 г., 8:59:14 (10 лет назад)

var
  b: integer;  

begin
  write('Введите целое число в переменную B.', #13, 'B := ');
  readln(b);
  writeln('B = ', b);
end.

Ответить

Другие вопросы из категории

Дима, Боря и Костя отправились собирать металлолом. Они на­шли увесистую деталь, погрузили ее на тележку и повезли.

Вот нам повезло, — сказал Дима по дороге. — Эта штука из чистой меди, да и весит килограммов тридцать.
Какая там медь? — возразил Боря. — Это ржавое железо. Но ты не унывай. В нем сто килограммов будет.
Да, это явно не медь, — вмешался Костя, — а весу пятьдесят килограммов, я думаю, наберется.


Каждый из ребят оказался прав только в одном из своих предпо­ложений.

4. Вычислить значения выражений:

a. (1 v 0) ^ (1 ^ a)
b. ((1 v 0) ^ (1 ^ 0)) v (0 v 1)
c. a ^ 0 v 1 v a
d. (a v 1) v (b v 0)
e. a ^ 1 v (a v 1) ^ 0

Читайте также

1. Разработать схему алгоритма для ввода четырёх целых чисел и вычисления их среднего арифметического.

Протестировать алгоритм на различных исходных данных (включая вещественные числа) и доказать правильность его работы.

2. Вводятся величины X,Y целого типа. Разработать схему алгоритма для обмена значений величин. Необходимо использовать вспомогательную величину Т. Протестировать алгоритм для X=5 и Y=-11.

Задание № 1) Разработать блок схему алгоритма, который проверяет, является ли четным введенное с клавиатуры число

Задание 2) Разработать блок схему алгоритма? для вычисления и вывода на экран суммы 5 случайных числе в диапазоне 0..36.

1.Напишите команды, которые выполняют следующие действия: а) вывод переменной с ;б) описать переменные а и s целого типа; в) переменной r присваивает

разность чисел p и q.
2.Что будет на экране после выполнения следующих команд: а) Writeln(9); Write(5); Writeln(3); б) Writeln(4*2); Write('5-3'); Writeln('5+1=',5+1);
3.Укажите различия циклов While и Repeat
4.Дана строка. Определить сколько пробелов в этой строке
6.Дано четырехзначное число. Вывести на экран сумму цифр этого числа
7.Найти количество цифр целого числа N
8.Напишите команды, которые выполняют следующие действия: а) ввод переменной d б) описать переменные m и n вещественного типа. в) переменной s присвоить разность чисел p и q
9.Что будет на экране после выполнения следующих команд: Writeln(5-3); Write('5+3'); Writeln('5*4=',5*4);
10.Когда нельзя применять цикл for
11.Дана строка. Определить сколько букв в этой строке
12.Дано трехзначное число. Вывести на экран все его цифры столбиком
13. Найти количество цифр целого числа N(+блок-схема)

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

Написать программу, которая считает и выводит на экран сумму всех целых чисел из промежутка [A, B]. Числа A и B задает пользователь.

Программу реализовать с помощью трех циклических алгоритмов:
1) Цикл со счетчиком for
2) Цикл с предусловием while
3) Цикл с постусловием repeat
В программе предусмотреть ситуацию, когда пользователь вводит значение B ‹ A
Пример 1:
Пользователь вводит числа A=5, B=10. Сумма чисел: 5+6+7+8+9+10. Вывод на экран: 45
Пример 2:
Пользователь вводит числа A=7, B=4. Сумма чисел: 4+5+6+7. Вывод на экран: 22
Пример 3:
Пользователь вводит числа A=5, B=5. Сумма чисел: 5. Вывод на экран: 5



Вы находитесь на странице вопроса "Разработать. Схему алгоритма, который запрашивает ввод целого числа в переменную В и выводит это число на экран. Отгладить алгоритм и проверить его прав", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.